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INTRODUÇÃO

Este Curso tem por objetivo ensinar criar animações com o programa Flash 4.0 da Macromedia e é aceito sem plugin no Windows 98 , Internet Explorer 4.0 ou superior e Netscape 4.5 ou superior. Versões anteriores destes browsers necessitam de plugin que pode ser obtido no próprio site da Macromedia.


Para puxar o Flash 4.0 versão demo de 30 dias : Site da Macromedia 

MENU DO FLASH

PRIVATE
FILE  - ARQUIVO 


New
criar novo arquivo

Open
abrir arquivo

Open as Library 
abrir arquivo com biblioteca

Close
fechar arquivo

Save
salvar arquivo

Save as
salvar arquivo como

Revert
voltar para a última vez que salvou arquivo

Import
importar imagens ou sons

Export Movie
exportar animação , ou seja , arquivo.swf

Export Image
exportar imagem

Publish Settings
parâmetros para publicar

Publish Preferences
preferências para publicar

Publish
publicar

Page Setup
parâmetros da página

Print Preview
previsão da impressão

Print
imprimir

Send
enviar

Preferences
preferências

Assistant
assistente

PRIVATE
EDIT - EDITAR


Undo
voltar à ultima modificação

Redo
avançar para próxima modificação

Cut
recortar

Copy
copiar

Paste
colar

Paste in Place
colar no lugar

Paste Special
colar especial

Clear
deletar

Duplicate
duplicar

Select All
selecionar tudo

Deselect All
deselecionar tudo

Copy Frames
copiar frames

Paste Frames
colar frames

Edit Symbol
editar símbolo

Edit Selected
editar seleção

Edit All
editar tudo

Insert Object
inserir objeto

Links


Objeto


PRIVATE
VIEW - VISUALIZAR


Go to
ir para

100%
visualizar o tamanho original da animação

Show Frames
exibir frames

Show All
exibir tudo

Outlines
exibir contornos

Fast


Antialias
não exibir serrilhamento no objeto

Antialias Text
não exibir serrilhamento no texto

Timeline
exibir linha do tempo

Work Area
exibir área de trabalho

Rulers
exibir réguas

Grid
exibir grade

Snap
exibir imã

Show Shape Hints
exibir shape hints, quando se usa o efeito Shape

PRIVATE
INSERT - INSERIR


Convert to Symbol
transformar para símbolo

New Symbol
criar novo símbolo

Layer
inserir camada

Motion Guide
inserir efeito Motion Guide

Frame
inserir frame ( quadro )

Delete Frame
deletar ( quadro )

Keyframe
inserir novamente o mesmo objeto do último frame 
( quadro )

Blank Keyframe
inserir um frame ( quadro ) vazio

Clear Keyframe
deletar frame ( quadro )

Create Motion Tweening
criar efeito Motion Tweening

Scene
inserir cena nova

Remove Scene
remover cena

PRIVATE
MODIFY - MODIFICAR




Instance
modificar instância



Frame
modificar frame ( quadro )



Layer
modificar layer ( camada )



Scene
modificar cena



Movie
modificar animação



Font
modificar fonte



Paragraph
modificar parágrafo



Style
modificar estilo da fonte : plano, negrito , itálico e alinhamento



Kerning
modificar espaço entre as linhas do texto



Text Field
modificar campo de preenchimento



Transform
Scale

modificar escala


Rotate

modificar rotação


Scale and Rotate

modificar escala e rotação


Rotate Left

rotacionar à esquerda


Rotate Right

rotacionar à direita


Flip Vertical

rotacionar 180º na vertical


Flip Horizontal

rotacionar 180º na horizontal


Remove Transform

remover modificações


Edit Center

editar centro


Remove Colors

remover cores


Add Shape Hints

adicionar Shape Hints ( Efeito Shape )


Remove Shape Hints

remover Shape Hints ( Efeito Shape )

Arrange
Bring to Front

trazer para frente


Move Ahead




Move Behind

mandar para trás


Send to Back




Lock

trancar


Unlock All

destrancar tudo

Curves
Smooth




Straighten




Optimize

otimizar


Lines to Fills




Expand Shape




Soften Edges



Frames
Reverse

reverter frames ( quadros )


Synchronize Symbols

sincronizar símbolos

Trace Bitmap




Align

alinhar


Group

agrupar


Ungroup

desagrupar


Break Apart

modificar imagem ou transformar texto em imagem para ser reeditado no Flash


PRIVATE
CONTROL - CONTROLAR


Play
rodar animação

Rewind
voltar a animação

Step Forward
ir à próxima cena da animação

Step Backward
voltar à última cena da animação

Test Movie
testar animação ( Crtl + Enter )

Test Scene
testar animação ; selecionar 1º frame da Cena ( Enter )

Loop Playback


Enable Frame Actions
ativar ações do frame

Enable Buttons
ativar botões

Mute Sounds
parar todos os sons

PRIVATE
LIBRARIES - BIBLIOTECAS


Buttons
botões

Buttons-Advanced
botões avançados

Graphics
gráficos

Movie Clips
trechos de animações

Sounds
sons

PRIVATE
WINDOW - JANELA



New Window
nova janela


Arrange All



Cascade



Toolbar
exibir os ícones das ferramentas


Inspectors
Object



Frame



Transform



Scene



Generator


Controler



Colors



Output



Generator Objects
abrir objetos do Generator , caso tenha este programa instalado no seu computador


Library
abrir sua biblioteca


PRIVATE
HELP - AJUDA


Flash Help Topics
tópicos de ajuda sobre o Flash

Register Flash
registrar o Flash on line

Flash Developers Center
visitar o site do Centro de Desenvolvedores de Flash on line 

Lessons
lições

Samples
exemplos

About Flash
sobre o Flash

FERRAMENTAS DO FLASH

Todas as ferramentas do Flash possuem ferramentas auxiliares
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PRIVATE

FERRAMENTA ARROW ( SETA ) - selecionar objeto

Ferramentas Auxiliares da Seta

Snap – Imã , para desenhar polígono quadrado e oval perfeitos manter a ferramenta imã ativada
Smooth – suavizar o contorno
Straigthen – modificar cantos do contorno
Rotate – rotacionar objeto
Scale – aumentar ou diminuir tamanho do objeto

[image: image2.bmp]Duplo clique sobre objeto – seleciona todo o objeto
Um clique sobre objeto – seleciona somente a parte do objeto que está sendo clicada
Shift + clique – clique nas partes do objeto que queira adicionar na seleção
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PRIVATE

FERRAMENTA LASSO ( LAÇO ) - seleciona parte do objeto com a
 mesma tonalidade ou seleciona parte do objeto manualmente

Ferramentas Auxiliares do Laço

Magic Wand ( Varinha Mágica ) - seleciona parte do objeto com a mesma tonalidade

Magic Wand Properties ( Propriedades da Varinha Mágica ) - determina área de abrangência da seleção

Polygon Mode ( Varinha Mágica Poligonal )- seleciona manualmente parte do objeto

[image: image4.bmp]
FERRAMENTA LINE ( LINHA ) - desenhar linha

[image: image5.bmp]
Ferramentas Auxiliares da Linha

Line Color - Cor do contorno

Stroke color focus –

Line Thickness – Tipos de Contornos
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Line Style – Estilo de Contornos

[image: image7.bmp]PRIVATE

FERRAMENTA TEXT ( TEXTO ) - inserir texto

Ferramentas Auxiliares do Texto


Font – tipo de fonte

Font Size – tamanho da fonte

Text Color – Cor do Texto

Bold – Negrito

Italic – Itálico

Alignment – Alinhamento : à esquerda , centralizado , à direita e justificado

Paragraphs – redimensionar parágrafos

[image: image8.bmp]Text Field – Inserir campo de preenchimento para formulários

PRIVATE

FERRAMENTA OVAL - inserir polígonos redondos

[image: image9.bmp]
Ferramentas Auxiliares da Oval


Line Color - Cor do contorno

Stroke Color Focus –

Line Thickness – Tipos de Contornos

Line Style – Estilo de Contornos

Fill Color – Cor do preenchimento

[image: image10.bmp]Fill Color Focus –

PRIVATE
FERRAMENTA RECTANGLE ( RETÂNGULO ) - 
inserir polígono retangular

[image: image11.bmp]
Ferramentas Auxiliares do Retângulo


Line Color - Cor do contorno

Stroke Color Focus –

Line Thickness – Tipos de Contornos

Line Style – Estilo de Contornos

Fill Color – Cor do preenchimento

Fill Color Focus –

Round Rectangle Radius – Inserir cantos arredondados para polígono retangular
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[image: image13.bmp]PRIVATE
FERRAMENTA PENCIL ( LÁPIS ) - desenhar à mão livre

Ferramentas Auxiliares do Lápis


Pencil Mode – Tipos de lápis

* Straigthen –

* Smooth –

* Ink - Tinta Nakin

Line Color - Cor do contorno

Stroke Color Focus –

Line Thickness – Tipos de Contornos

Line Style – Estilo de Contornos

[image: image14.bmp]
[image: image15.bmp]PRIVATE
FERRAMENTA BRUSH ( PINCEL ) - desenhar com pincel

Ferramentas Auxiliares do Pincel


Brush Mode :

* Paint Normal – pintar normal

* Paint Fills – pintar preenchimentos

* Paint Behind – pintar atrás

* Paint Selection – pintar seleção

* Paint Inside – pintar dentro

Fill Color – cor de preenchimento
Brush Size – tamanho do pincel

Brush Shape – tipo de pincel

[image: image16.bmp]
PRIVATE

FERRAMENTA NANKIN - pintar contornos

[image: image17.bmp]
Ferramentas Auxiliares do Nankin


Line Color - Cor do Contorno

Stroke Color Focus –

Line Thickness – Tipos de Contornos

[image: image18.bmp]Line Style – Estilo de Contornos

[image: image19.bmp]PRIVATE
FERRAMENTA PAINT BUCKET ( Balde de Tinta ) - 
pintar parte de dentro do objeto

Ferramentas Auxiliares do Balde de Tinta


Fill Color – Cor de preenchimento

Gap Size - ( Controle de Preenchimento )


* Don’t Close Gaps - não pinta dentro da imagem que tiver o caminho aberto ( path )  do polígono


* Close Small Gaps - pinta dentro imagem que tiver  um pequeno caminho aberto ( path ) do polígono


* Close Medium Gaps - pinta dentro imagem que tiver caminho médio aberto ( path ) do polígono


* Close Large Gaps - pinta dentro imagem que tiver  um grande caminho aberto ( path ) do polígono

[image: image20.bmp]Transform Fill – em cores gradientes determinar posição da luz
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PRIVATE


PRIVATE "TYPE=PICT;ALT=gotas.gif (149 bytes)"FERRAMENTA DROPPER ( Conta Gotas ) 
- captar cor usada no objeto

[image: image22.bmp]PRIVATE

FERRAMENTA ERASER ( Borracha )

Ferramentas Auxiliares da Borracha
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Eraser Mode – Tipos de Borracha :
* Erase Normal – borracha normal
* Erase Fills – apagar preenchimentos
* Erase Line – apagar linhas
* Erase Selected Fills – apagar preenchimentos selecionados
* Erase Inside – apagar dentro do objeto
Faucet - Torneira - apagar áreas fechadas do preenchimento
Eraser Shape – Tipos de Borracha

[image: image24.bmp]PRIVATE
FERRAMENTA HAND ( Mão ) - movimentar objeto

PRIVATE
FERRAMENTA ZOOM - visualizar objeto
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Ferramentas Auxiliares do Zoom

Zoom ( + ) - para ampliar visualização do objeto
Zoom ( - ) - para reduzir visualização do objeto
[image: image26.bmp]
OUTRAS FERRAMENTAS

FERRAMENTA PARA CORES EM GRADIENTE

· [image: image27.png][Times =]




Clique no ícone Fill Color ( Cor de Preenchimento )

· Clique no ícone Gradiente

[image: image28.bmp]
· Abrirá Caixa de Diálogo > Gradiente :


1. Clique em New ( Novo ) para criar novo gradiente ( opcional )

2. Formas de Gradiente : Linear ou Radial

3. Paletas de cores

4. Cores em RGB ; caso ( x ) Hex - Cores em Hexagonal

5. Seletor de Cores

6. Intensidade da Cor

7. Outras formas da Cor :
Add Colors - adicionar cor
Replace Colors - recolocar cor
Load Default Colors - carregar cores default
Save Colors - salvar cor
Save as Default - salvar cor como default
Clear Colors - deletar cor
Web 216 - usar 216 cores para Web
Sort by Color - tipo de cor
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FERRAMENTA TRANSFORM FILL
para mudar posição da luz no objeto

· [image: image30.bmp]Clique na ferramenta Transform Fill

· Clique sobre o objeto e movimente as arestas para modificar a luminosidade

· Deselecione a ferramenta Transform Fill

CENAS E SÍMBOLOS

[image: image31.png]


Scene 1 - Visualiza Cena

[image: image32.bmp]
1. Para adicionar nova Cena : Insert > Scene

2. Seleciona Símbolo para ser reeditado

3. Para criar novo símbolo : Insert > New Symbol ou

4. Seleciona objeto > F8

[image: image33.png]



Symbol 1 - Seleciona Símbolo para ser reeditado

Para criar novo símbolo : Insert > New Symbol ou

Seleciona objeto > F8

Symbol - Visualiza Símbolo

LAYER CAMADA

Olho - visualizar o esconder layer

Cadeado - trancar ou destrancar layer

Quadrado - exibir ou não somente os contornos do layer 

[image: image34.bmp]
Add Layer ( folha branca ) - adicionar layer ( camada )

[image: image35.png]


Add Layer Guide ( folha lilás ) - adicionar layer guide , usado no efeito Add Motion Guide

[image: image36.bmp]Delete Layer - deletar layer ( camada )

FRAMES - QUADROS
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Center Frame - Frame que está sendo selecionado

Onion Skin ( Casca de Cebola ) - para fazer Add Motion Guide

Onion Skin Outlines ( Contornos da Casca de Cebola ) - para visualizar os contornos do Add Motion Guide

Edit Multiples Frames ( Edita Múltiplos Frames ) - para selecionar os frames que serão editados em Add Motion Guide

Modify Onion Markers ( Modifica Marcadores da Cebola ) :

  * Always Show makers - exibir sempre os marcadores

  * Anchor Onion - exibir cebola ancora

  * Onion 2 - exibir cebola dois

  * Onion 5 - exibir cebola cinco

  * Onion All - exibir todas as cebolas

1 - determina quantos frames tem a animação

12.0 fps - determina quantos frames / segundo

0.0s - determina o tempo de duração da animação

CONCEITOS FUNDAMENTAIS

[image: image38.png]


TIMELINE - LINHA DO TEMPO

Bolinha preta - Keyframe , isto é , há desenho na linha do tempo = 1

Bolinha branca - Blank Keyframe , isto é , não há desenho na linha do tempo = 5

Linha preta - Frame , isto é , repete a penúltima linha do tempo na linha = 10 que pode ser um keyframe ou blank keyframe

ALINHAMENTO DE DESENHO

[image: image39.png]i X

o0 =

=

SpaceEventy | O3

Bz

00
=




Para alinhar  > seleciona o desenho > Crtl K ou  Modify > Align

Alinhamento pode ser na Vertical , Horizontal e Tamanho da Área de Trabalho 
( Match Size )

X - não alinha desenho

Space Evently - alinha o espaço entre desenhos

Cruz que está no Match Size - expande o objeto para o tamanho da tela

Align to Page - alinha o desenho no meio da Área de Trabalho

TAMANHO DA ÁREA DE TRABALHO
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Para modificar o tamanho da área de trabalho > clique em 12.0 fps
Frame Rate - define quantos frames por segundo , por default 12.0

Dimensions - define as dimensões da área de trabalho

Match - Printer - define tamanho exato da impressão

Match - Contents - reajusta o tamanho da tela para somente o espaço que foi ocupado a animação

Grid Spacing - define tamanho da grade

Grid - exibir ou não a grade para auxiliar a desenhar a animação

Colors - Grid - define a cor da grade

Colors - Background - define a cor do fundo da animação

[image: image41.png]


TÉCNICA PARA MODIFICAR FORMA DO DESENHO

1. Desenhe uma bola

2. Clique na ferramenta seta ( Arrow ) e arraste uma das bordas para fora para redefinir forma do desenho

EFEITO TWEENING MOTION

O efeito Motion Tweening é a animação de um objeto em duas sequências em linha reta

Rotação : Automatic ( Automática ) , Clockwise ( Sentido Anti-Horário ) e Counterclockwise ( Sentido Horário ) ;

Easing ( Aceleração )

EXERCÍCIO 01 - MOTION COM OBJETO

1. Desenhe uma bola

2. Clique na ferramenta Arrow ( Seta ) ;

3. Clique duas vezes sobre a bola para selecionar toda a bola 
( contorno e preenchimento )

4. Aperte a tecla F8 para transformar a bola em símbolo

5. Abrirá uma Caixa de Diálogo : Name : bola ; behavior : graphic ;
Observe que quando se cria um símbolo , aparece um sinal ( + ) dentro do objeto

6. Selecione a linha do tempo = 50

7. Insira um keyframe na linha do tempo = 50 ou seja aperte a tecla F6 ou botão direito do mouse > Insert > Keyframe

8. Quando se insere um keyframe, estamos repetindo o objeto do frame anterior ; mas para que haja animação devemos mudar a posição do objeto referente a linha do tempo = 50 , no caso a bola ; para outra posição

9. Selecione a linha do tempo = 1 ;
botão direito do mouse > Create Motion Tweening , para inserir o efeito tweening motion ; observe que na linha do tempo entre a linha 1 até 49 foi exibido uma linha em cor preta, significando que nesta etapa da animação há um Tweening Motion

10. Salve sua animação , neste caso , exer01.fla

11. Há duas maneiras de exportar a animação ou seja para rodar a animação :
Crtl + Enter > exer01.fla se transforma em exer01.swf ou
File > Export Movie > exer01.fla se transforma em exer01.swf

12. Para voltar à   área de trabalho > Crtl + F4

EXERCÍCIO 02 - MOTION COM TEXTO

1. Selecione a ferramenta Text ( Texto ) ;
Escolha fonte Arial Black, tamanho 28 e cor azul

2. Digite a palavra : FLASH

3. Clique na ferramenta Arrow ( Seta ) ;
Clique sobre o texto

4. Aperte a tecla F8 para transformar o texto em símbolo

5. Abrirá uma Caixa de Diálogo : Name : texto ; behavior : graphic ;
Observe que quando se cria um símbolo , aparece um sinal ( + ) dentro do texto

6. Selecione a linha do tempo = 50

7. Insira um keyframe na linha do tempo = 50 ou seja aperte a tecla F6 ou botão direito do mouse > Insert > Keyframe

8. Quando se insere um keyframe, estamos repetindo o objeto do frame anterior ; mas para que haja animação devemos mudar a posição do objeto referente a linha do tempo = 50 , no caso o texto ; para outra posição

9. Selecione a linha do tempo = 1 ;
Selecione o texto > Modify > Transform > Scale and Rotate ;
Scale : 10 e Rotate : 0

10. Selecione a linha do tempo = 1 ;
botão direito do mouse > Create Motion Tweening , para inserir o efeito tweening motion ; observe que na linha do tempo entre a linha 1 até 49 foi exibido uma linha em cor preta, significando que nesta etapa da animação há um Tweening Motion

11. Salve sua animação , neste caso , exer02.fla

12. Há duas maneiras de exportar a animação ou seja para rodar a animação :
* Crtl + Enter > exer02.fla se transforma em exer02.swf ou
* File > Export Movie > exer02.fla se transforma em exer02.swf

13. Para voltar à   área de trabalho > Crtl + F4

EXERCÍCIO  03  - MOTION COM TEXTO E OBJETO

1. Selecione a ferramenta Oval ;
Escolha contorno em preto e preenchimento em azul claro

2. Desenhe uma bola no lado esquerdo, na parte superior

3. Clique na ferramenta Arrow ( Seta ) ;
Clique duas vezes sobre a bola para selecionar toda a bola 
( contorno e preenchimento )

4. Aperte a tecla F8 para transformar a bola em símbolo

5. Abrirá uma Caixa de Diálogo : Name : bola1 ; behavior : graphic ;
Observe que quando se cria um símbolo , aparece um sinal ( + ) dentro do objeto

6. Clique sobre a bola1 com o botão direito do mouse > Properties

7. Colors Effects > Alpha > Alpha : 40

8. Selecione a linha do tempo = 50 > F6 para inserir keyframe

9. Crtl + K para centralizar a bola :
Vertical > Align > selecione o terceiro botão ;
Horizontal > Align > selecione o terceiro botão ;
Match Size > selecione o primeiro botão ( x ) ;
( x ) marque Align to Page

10. Modify > Transform > Scale and Rotate :
Scale : 900 ; Rotate : 0

11. Clique duas vezes sobre o layer 1 e renomeie para bola1

12. Clique no ícone Add Layer  ( folha branca ) criando o layer 2

13. Clique duas vezes sobre o layer 2 e renomeie para texto1

14. Selecione a linha do tempo = 1

15. Selecione a ferramenta Text ( Texto ) ; fonte : verdana ; tamanho 48 ; cor : vinho
Digite : TESTANDO

16. Crtl + K para centralizar o texto :
Vertical > Align > selecione o terceiro botão ;
Horizontal > Align > selecione o terceiro botão ;
Match Size > selecione o primeiro botão ( x ) ;
( x ) marque Align to Page

17. Selecione a ferramenta Arrow ( Seta ) ;
Clique sobre o texto

18. Aperte a tecla F8 para transformar o texto em símbolo

19. Abrirá uma Caixa de Diálogo : Name : texto1 ; behavior : graphic ;
Observe que quando se cria um símbolo ,  aparece um sinal ( + ) dentro do texto

20. Selecione a linha do tempo = 50 > F6 para inserir keyframe

21. Selecione a linha do tempo = 1

22. Selecione o texto > Modify > Transform > Flip Vertical

23. Clique sobre a linha do tempo 1 > botão direito do mouse > Create Tweening

24. Salve o arquivo como exer03.fla

25. Crtl + Enter e teste sua animação

26. Crtl + F4 para voltar a área de trabalho

EXERCÍCIO 04 - MOTION COM CLOCKWISE

1. Clique duas vezes no ícone 12.0 fps  
Background mude o fundo da animação para preto

2. Desenhe uma bolinha com a cor azul

3. Selecione a ferramenta Arrow ( Seta ) e clique sobre a borda da bolinha ;
delete a borda

4. Clique sobre a bolinha > Crtl + D para duplicar

5. Usando seu teclado , clique na tecla das setinhas e arraste sua bolinha para fora

6. Pinte a segunda bolinha de verde

7. Selecione a bolinha verde > Crtl + D para duplicar

8. Usando seu teclado , clique na tecla das setinhas e arraste sua bolinha para fora

9. Pinte a terceira bolinha de vermelho

10. Selecione a bolinha vermelha > Crtl + D para duplicar

11. Usando seu teclado , clique na tecla das setinhas e arraste sua bolinha para fora

12. Pinte a quarta bolinha de roxo

13. Selecione a bolinha roxa > Crtl + D para duplicar

14. Usando seu teclado , clique na tecla das setinhas e arraste sua bolinha para fora

15. Pinte a quinta bolinha de laranja

16. Selecione a bolinha laranja > Crtl + D para duplicar

17. Usando seu teclado , clique na tecla das setinhas e arraste sua bolinha para fora

18. Pinte a sexta bolinha de amarelo

19. Selecione cada bolinhas separadamente e faça um círculo com elas usando a tecla das setinhas do seu teclado

20. Selecione todas as bolinhas > F8 para transformar em símbolo

21. Name : bolinhas ; behavior : graphic

22. Selecione a linha do tempo = 40 > F6 para inserir keyframe

23. Selecione a linha do tempo = 1 > Create Motion Tweening

24. Clique o botão direito do mouse sobre a linha do tempo = 1 > Properties

25. Tweening > Motion > Rotate : Clockwise e digite 999 times ( vezes ) ;
No item Easing ( aceleração ) :
In > a animação fica rápida e no final devegar
Out > a animação fica devegar e no final rápida
Geralmente deixar em default, isto é, no meio entre In e Out

26. Salve o arquivo como exer04.fla

27. Crtl + Enter e teste sua animação

28. Crtl + F4 para voltar a área de trabalho

EXERCÍCIO 05 - EFEITO FADE COM TEXTO

1. Clique duas vezes no ícone 12.0 fps  
Background mude o fundo da animação para preto

2. Selecione a ferramenta Text ( Texto ) ;
fonte : arial black ; tamanho 48 ; cor : branco ;
digite : FLASH

3. Selecione a ferramenta Arrow ( Seta )
Clique sobre o texto

4. Aperte a tecla F8 para transformar o texto em símbolo

5. Abrirá uma Caixa de Diálogo : Name : texto2 ; behavior : graphic ;
Observe que quando se cria um símbolo ,  aparece um sinal ( + ) dentro do texto

6. Selecione a linha do tempo = 50 > F6 para inserir keyframe

7. Selecione a linha do tempo = 1 > Create Motion Tweening

8. Clique sobre o texto com o botão direito do mouse > Properties

9. Colors Effects > Alpha > Alpha : 0

10. Salve o arquivo como exer05.fla

11. Crtl + Enter e teste sua animação

12. Crtl + F4 para voltar a área de trabalho

EFEITO ADD MOTION GUIDE

O efeito Add Motion Guide é a maneira que você cria os caminhos por onde passará sua animação ,mas para que ocorra o Add Motion Guide, você deve criar primeiramente o Motion Tweening  

( conforme mencionamos no capítulo anterior )

EXERCÍCIO 06  - ADD MOTION GUIDE

1. Desenhe uma bola
Clique na ferramenta Arrow ( Seta ) ;

2. Clique duas vezes sobre a bola para selecionar toda a bola 
( contorno e preenchimento )

3. Aperte a tecla F8 para transformar a bola em símbolo

4. Abrirá uma Caixa de Diálogo : Name : bola ; behavior : graphic ;
Observe que quando se cria um símbolo > aparece um sinal ( + ) dentro do objeto

5. Selecione a linha do tempo = 50

6. Insira um keyframe na linha do tempo = 50 ou seja aperte a tecla F6 ou
botão direito do mouse > Insert > Keyframe

7. Quando se insere um keyframe, estamos repetindo o objeto do frame anterior ;
mas para que haja animação devemos mudar a posição do objeto referente a linha do tempo = 50 , no caso a bola ; para outra posição

8. Selecione a linha do tempo = 1 ;
botão direito do mouse > Create Motion Tweening , para inserir o efeito tweening motion ; observe que na linha do tempo entre a linha 1 até 49 foi exibido uma linha em cor preta, significando que nesta etapa da animação há um Tweening Motion

9. Clique na folha lilás ( Add Guide ) 

10. Clique no ícone  Edit Multiple Frames ( Editar múltiplos frames )

11. Na linha do tempo ao clicar o ícone Edit Multiple Frames aparecerá um marcador em cinza que deve ser arrastado para cada eixo da animação, isto é , um para linha do tempo = 1 e o outro para linha = 50

12. Clique na ferramenta Pencil ( Lápis ) e escolha o modo Smooth ( traçado suave )

13. As duas bolas devem estar selecionada

14. Selecione a ferramenta imã 

15. Desenhe o caminho por onde passará a bola , iniciando dentro do sinal ( + ) de uma das bolas e terminando no eixo ( + ) da outra bola

16. Sempre ao terminar o Add Motion Guide > desativar o ícone Edit Multiple Frames

17. Salve sua animação, neste caso, exer06.fla

18. Há duas maneiras de exportar a animação ou seja para rodar a animação :
* Crtl + Enter ou
* File > Export Movie

19. Para voltar à área de trabalho > Crtl + F4

EXERCÍCIO 07  DANÇA DAS LETRAS

1. Digite em Arial Black ; tamanho 48 , azul ,a palavra : A M O R ( com espaço )

2. Selecione a ferramenta Arrow ( Seta )

3. Crtl + K para centralizar no meio na página

4. Mantenha o texto selecionado > Ctrl + B ou Modify > Break Apart, para transformar o texto em imagem

5. Selecione somente a letra A > F8 > symbol : A ; behavior : graphic

6. Selecione somente a letra M e usando a ferramenta balde, pois a palavra deixou de ser texto e é uma imagem e pinte de vermelho

7. Mantenha o M selecionado > F8 > symbol : M ; behavior : graphic

8. Selecione somente a letra O e usando a ferramenta balde, pois a palavra deixou de ser texto e é uma imagem e pinte de verde

9. Mantenha o O selecionado > F8 > symbol : O ; behavior : graphic

10. Selecione somente a letra R e usando a ferramenta balde, pois a palavra deixou de ser texto e é uma imagem e pinte de laranja

11. Mantenha o R selecionado > F8 > symbol : R ; behavior : graphic

12. Selecione a linha do tempo = 1 > botão direito do mouse > Copy Frame 
( Copiar Frame )

13. Clique no ícone  Add Layer ( Adicionar Layer ) três vezes , pois a palavra tem quatro letras e como já tínhamos um layer, precisamos de mais três layers

14. Selecione a linha do tempo = 1 de cada layer récem-criado separadamente > botão direito do mouse > Paste Frame ( Colar Frame )

15. Clique duas vezes sobre o primeiro layer e renomeie para A

16. Clique duas vezes sobre o segundo layer e renomeie para M

17. Clique duas vezes sobre o terceiro layer e renomeie para O

18. Clique duas vezes sobre o quarto layer e renomeie para R

19. Selecione a linha do tempo = 50 dos quatro layers > F6 para inserir keyframe

20. Clique no ícone  olho para esconder o layer M , O , R

21. Selecione a linha do tempo = 1 do layer A

22. Selecione na área de trabalho as letras M , O , R > delete

23. Selecione a linha do tempo = 50 do layer A

24. Selecione na área de trabalho as letras M , O , R > delete

25. Mantendo a linha do tempo 1 coloque a letra A na parte superior à direita da tela 

26. Clique na linha do tempo = 1 > botão direito do mouse > Create Tweening

27. Clique na folha lilás ( Add Guide ) 

28. Clique no ícone  Edit Multiple Frames ( Editar múltiplos frames )

29. Na linha do tempo ao clicar o ícone Edit Multiple Frames aparecerá um marcador em cinza que deve ser arrastado para cada eixo da animação, isto é , um para linha do tempo = 1 e o outro para linha = 50

30. Selecione a letra A nas duas posições

31. Selecione a ferramenta imã 

32. Selecione a ferramenta Pencil ( Lápis ) e desenhe o caminho por onde passará a bola , iniciando dentro do sinal ( + ) de um A e terminando no eixo ( + ) do outro A

33. Windows > Controller para abrir o Controlador e aperte play para testar a movimentação da letra A , caso não tenha feito a movimentação desenhada por você > Crtl + Z e volte a desenhar o caminho novamente

34. Sempre ao terminar o Add Motion Guide > desativar o ícone Edit Multiple Frames

35. Esconda também o Layer : Guide A

36. Repita o mesmo procedimento com as outras letras, escondendo sempre os layers das letras que não esteja trabalhando ; siga as instruções dos itens 20 ao 33 , selecionando em cada letra na linha do tempo = 1 com posições diferentes.

37. Terminando todas as letras clique no olho para visualizar todos os layers

38. Salve sua animação, neste caso , exer07.fla

39. Crtl + Enter

40. Para voltar à área de trabalho > Crtl + F4

EFEITO SHAPE

O efeito Shape transforma um objeto em outro, conhecido também como morphing ; 

Os objetos não podem ser símbolos

Tipos de Mistura ( Blend Type ):

· Distributive - os desenhos dos frames do meio da animação ficam irregulares e suaves

· Angular - os desenhos dos frames do meio da animação mantém as linhas e os cantos

Easing ( Aceleração )

EFEITO ADD SHAPE HINTS

[image: image42.png]


Para controlar melhor a deformação do morphing é usado o Efeito Add Shape Hints através de marcadores , mas ele só funciona se criar primeiro um shape entre dois objetos
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EXERCÍCIO 08 -  SHAPE COM POLÍGONOS

1. Desenhe um quadrado

2. Clique na ferramenta Arrow ( Seta ) ;
Selecione o contorno do quadrado e delete

3. Selecione a linha do tempo = 15 > F6 para inserir um Keyframe

4. Clique na ferramenta do imã ativa para que ela esteja ativada

5. Desenhe um triângulo sobre o quadrado e pinte de outra cor

6. Selecione as partes restantes do quadrado e o contorno do triângulo e delete

7. Selecione a linha do tempo = 30 > F6 para inserir um Keyframe

8. Desative a ferramenta imã

9. Desenhe uma bola sobre o triângulo

10. Selecione as partes restantes do triângulo e o contorno da bola e delete

11. Selecione a linha do tempo = 1 até 29

12. Botão direito do Mouse > Properties > Tweening > Shape > Distributive

13. Salve sua animação , neste caso , exer08.fla

14. Crtl + Enter 

15. Para voltar à área de trabalho > Crtl + F4

EXERCÍCIO 09 - EFEITO DE IMAGEM COM TEXTO

1. File > Import e importe uma imagem com extensão png e 72 dpi de resolução

2. Selecione a ferramenta Arrow ( Seta )

3. Selecione a imagem > Crtl + B  ou Modify > Break Apart para transformar a imagem em bitmap

4. Insira um keyframe na linha do tempo = 50

5. Deselecione a imagem

6. Digite sobre a imagem : E F E I T O em arial back, 48 e pinte de uma cor

7. Clique sobre a imagem e delete

8. Selecione o texto  > Crtl + B  ou Modify > Break Apart para transformar o texto em bitmap

9. Selecione a linha do tempo = 1 até 49

10. Botão direito do Mouse > Properties > Tweening > Shape > Angular

11. Salve sua animação , neste caso, exer09.fla

12. Crtl + Enter

13. Para voltar à área de trabalho > Crtl + F4

EXERCÍCIO 10  - ADD SHAPE HINTS COM POLÍGONO

1. Desenhe uma quadrado

2. Clique na ferramenta Arrow ( Seta ) ;
Selecione o contorno do quadrado e delete

3. Selecione a linha do tempo = 30 > F6 para inserir um Keyframe

4. Clique na ferramenta do imã para desativar

5. Desenhe uma bola sobre o quadrado

6. Selecione as partes restantes do quadrado e o contorno da bola e delete

7. Selecione a linha do tempo = 1 até 29

8. Botão direito do Mouse > Properties > Tweening > Shape > Distributive

9. Selecione a linha do tempo = 1

10. Modify > Transform > Add Shape Hints ;
será exibido uma bola amarela com a letra A

11. Arraste o A para uma extremidade do quadrado

12. Clique sobre A > botão direito do mouse > Add Hints ( Adicionar Hints )
Será exibido uma bola amarela com a letra B

13. Arraste o B para uma extremidade do quadrado

14. Repita as instruções mencionadas nos itens 12 à 14 e insira os hints C , D , E

15. Selecione a linha do tempo = 30

16. Será exibido uma bola verde E no meio do polígono , arraste para extremidade cada hints 

17. Salve sua animação , neste caso , exer10.fla

18. Crtl + Enter 

19. Para voltar à área de trabalho > Crtl + F4

SÍMBOLOS

Os símbolos podem ser :  graphic ( gráfico ) , button ( botão ) e movie clip ( pequena animação )

LIBRARIES estão as bibliotecas do Flash

[image: image44.bmp]buttons ( botões )
buttons-advanced ( botões avançados )
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graphics ( gráficos )
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movie clips ( pequenas animações )

[image: image47.bmp]
sounds ( sons )
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WINDOWS > LIBRARY
onde fica armazenado os símbolos criados por você

File > Import ( Arquivo > Importar )

quando se importa uma imagem, o Flash faz uma cópia automaticamente na sua biblioteca

[image: image49.bmp]
COMO PERSONALIZAR SUA LIBRARY ( Biblioteca )

Caso você queira armazenar seus símbolos preferidos de maneira personalizada

1. Crie um arquivo novo no Flash

2. Salve com seu nome : exemplo : beto.fla em Arquivos de Programas ou Program Files > Macromedia > Flash 4 > Libraries

3. Crie seus símbolos preferidos e salve seu arquivo

4. Feche seu arquivo personalizado

5. Crie uma nova animação

6. Libraries > seu_nome ( neste caso beto )

7. Escolha o símbolo que queira inserir na nova animação

COMO CRIAR UM SÍMBOLO

1. Window > Library ( Janela  > Biblioteca )

2. Options > New Symbol ( Opção > Novo Símbolo )

3. Name : digite o nome símbolo

4. Behavior : escolha o tipo do símbolo

5. Desenhe um símbolo

6. Terminado a edição do símbolo;
clique em Edit Scene ( Editar Cena )  ;
caso queira voltar na edição do símbolo > Edit Symbols ( Editar Símbolo )

7. Observe que o símbolo recém construído fica automaticamente dentro da Library 
( Biblioteca )

8. [image: image50.bmp]Para inserir o símbolo para Cena :
selecione na Library o símbolo ;
clique no desenho do símbolo e arraste para sua Cena

OUTRAS FERRAMENTAS PARA SÍMBOLOS

New Symbol > criar novo símbolo

New Folder > criar nova pasta

Properties > propriedades do símbolo

Delete > deletar símbolo
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Subir ou descer para o próximo símbolo

Aumentar a área de visualização sobre os símbolos

Diminuir a área de visualização sobre os símbolos

[image: image52.bmp]Ir para o primeiro símbolo

OPTIONS - OPÇÕES DO SÍMBOLO

New Symbol - criar novo símbolo

New Folder - criar nova pasta , ou seja , serve para organizar os símbolos por categorias

Rename - renomear símbolo

Move to New Folder - mover para nova pasta

Duplicate - duplicar símbolo

Delete - deletar símbolo

Edit - editar símbolo

Properties - propriedades do símbolo

Select Unused items - selecionar símbolos que não estão sendo usados

Update - atualizar símbolos

Play - rodar símbolo ( movie clip , botão e som )

Expand Folder - expandir pasta

Collapse Folder - fechar pasta

Expand All Folders - expandir todas as pastas

Collapse All Folders - fechar todas as pastas

Keep Use Counts Update

Keep Use Counts Now
PROPRIEDADES DE UM SÍMBOLO

DEFINITION - DEFINIÇÃO

Behavior  ( Comportamento ) - Graphic , Button , Movie Clip

Play Mode Option ( maneira para rodar a animação )


Graphic - determina quantas vezes irá rodar o símbolo gráfico :
Loop ( infinitamente ) , Play Once ( rodar uma vez ) , Single Frame ( símbolo fica estático )


Button - determina como funcionar o botão : Track as Button , Track as Menu Item

[image: image53.bmp]Movie Clip - determina a instância de um símbolo , ou seja, um símbolo movie clip pode ter várias instâncias , mas com ações diferentes : Instance Name ( Nome da Instância )

Switch Symbol


[image: image54.bmp]Edit Symbol - editar símbolo

[image: image55.bmp]Duplicate Symbol - duplicar símbolo

COLOR EFFECT - EFEITO DE COR

Um mesmo símbolo pode ter cores diferentes na área de trabalho

None - nenhuma mudança da forma original do símbolo

Brigthness - dar ou retirar brilho do símbolo 

Tint - pintar o símbolo de outra cor

Alpha - clarear o símbolo

Special - especificar a cor em RGB

ACTION - AÇÃO

Somente o símbolo button se dá uma ação no próprio botão , para os outros símbolos as ações são inseridas na linha do tempo 
( outros detalhes sobre as ações, veja o capítulo sobre Ações ) 

EXERCÍCIO 11 - SÍMBOLO MOVIE CLIP

1. Neste exemplo vamos criar uma árvore de natal

2. File > Import e importe uma imagem de uma árvore em extensão png com resolução de 72 dpi

3. Window > Library > Options > New Symbol para criar novo símbolo

4. Name: bolinhas ; behavior : movie clip

5. Desenhe uma bolinha pequena de cor vermelha gradiente

6. Selecione a borda e delete

7. Crtl + K para alinhar a bola no centro ( em cima do sinal + )
Vertical > Align > selecione o terceiro botão ;
Horizontal > Align > selecione o terceiro botão ;
Match Size > selecione o primeiro botão ( x ) ;
( x ) marque Align to Page

8. Selecione a linha do tempo = 2 > F6 ou Insert > Keyframe

9. Com a ferramenta balde pinte a bolinha de verde gradiente

10. Selecione a linha do tempo = 3 > F6 ou Insert > Keyframe

11. Com a ferramenta balde pinte a bolinha de cinza gradiente

12. Selecione a linha do tempo =4 > F6 ou Insert > Keyframe

13. Com a ferramenta balde pinte a bolinha de azul gradiente

14. Volte para edição da Cena 1 > Edit Scene 

15. Arraste a bolinha movie clip da library para a árvore por várias vezes

16. Selecione a linha do tempo = 40 > F5 ou Insert > Frame

17. Salve o arquivo como exer11.fla

18. Crtl + Enter e teste sua animação

19. Crtl + F4 para voltar a área de trabalho

EXERCÍCIO 12 - SÍMBOLO MOVIE CLIP

1. Neste exemplo vamos fazer a tela de um computador mudar de cor

2. File > Import e importe uma imagem de computador em extensão png com resolução de 72 dpi

3. Selecione a imagem > Crtl B ou Modify > Break Apart para transformar a imagem em bitmap

4. Selecione a ferramenta varinha mágica 

5. Clique na segunda varinha mágica > Magic Wand Properties ( Propriedades da Varinha Mágica )

6. Threshold : 10  e Smoothing : Normal

7. Selecione a primeira varinha mágica > Magic Wand ( Varinha Mágica )

8. Clique sobre a tela da imagem do computador , caso ela não selecione toda a tela, volta à segunda varinha mágica e aumente o Threshold para 20 e assim sucessivamente até que selecione toda a tela

9. Aperte F8 e transforme a tela em símbolo movie clip

10. Name: tela ; behavior : movie clip

11. Window > Library ( Janela > Biblioteca )

12. Selecione o símbolo tela e clique duas vezes sobre o desenho da tela

13. Insira um keyframe na linha do tempo = 2 e pinte de uma outra cor

14. Insira um keyframe na linha do tempo = 3 e pinte de uma outra cor

15. Insira um keyframe na linha do tempo = 4 e pinte de uma outra cor

16. Volte para edição da Cena 1 > Edit Scene 

17. Selecione a linha do tempo = 50 > F5 ou Insert > Frame

18. Salve o arquivo como exer12.fla

19. Crtl + Enter e teste sua animação

20. Crtl + F4 para voltar a área de trabalho

BOTÃO ANIMADO

ESTÁGIOS DO BOTÃO
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O botão tem quatro estágios  : 


Up - como o botão aparece sem passar o mouse

Over - como o botão aparece quando o mouse passa por cima do botão

Down - como o botão aparece quando você clica no botão

Hit - define a área " clicável " do botão, ou seja, a área em que ele é acionado

Observação : Quando se transforma um objeto em botão , ele tem uma opção : Tracking Options que possui duas opções : Track as Button que evita que outros botões recebam a Ação " On Mouse Events " enquanto o mouse está no estágio down ; Track as Menu Item que permite que outros botões recebam a Ação " On Mouse Events - Release "

EXERCÍCIO 13 - BOTÃO 1

1. Window > Library > Options > New Symbol

2. Name : botão1 ; behavior : button

3. Desenhe uma bola em azul

4. Clique duas vezes sobre a bola para selecionar o polígono e o contorno

5. Crtl + D ou  Edit > Duplicate para duplicar a bola

6. Com as setinhas do teclado arraste a cópia da bola para fora totalmente

7. Modify > Transform > Scale and Rotate

8. Scale : 90 ; Rotate : 0

9. Com as setinhas do teclado arraste a cópia da bola para o meio da primeira bola

10. Selecione a duas bolas > Crtl + G ou Modify > Group para agrupar as duas bolas, tornando-as um só polígono

11. Digite em branco e Arial Black no botão a palavra ENTRE

12. Selecione o botão > Crtl K para centralizar no sinal ( + ) o símbolo botão1

13. Vertical > Align > selecione o terceiro botão ;
Horizontal > Align > selecione o terceiro botão ;
Match Size > selecione o primeiro botão ( x ) ;
 ( x ) marque Align to Page

14. Selecione a linha do tempo os estágios Over, Down e Hit

15. F6 ou Insert > Keyframe

16. Selecione na linha do tempo o estágio Over

17. Modify > Transform > Scale and Rotate

18. Scale : 120 ; Rotate : 0

19. Selecione somente a palavra Entre

20. Selecione a ferramenta de Texto e troque a cor para amarelo

21. Selecione na linha do tempo o estágio Down

22. Modify > Transform > Scale and Rotate

23. Scale : 80 ; Rotate : 0

24. Selecione somente a palavra Entre

25. Selecione a ferramenta de Texto e troque a cor para verde

26. Deixe o estágio Hit como está , ou seja , igual ao estágio Up

27. Clique em Scene 1  para voltar a Cena 1

28. Arraste da Library ( Biblioteca ) o desenho do botão 1 para área de trabalho

29. Salve o arquivo como exer13.fla

30. Crtl + Enter e teste sua animação

31. Passe o mouse sobre o botão

32. Crtl + F4 para voltar a área de trabalho

EXERCÍCIO 14 - BOTÃO 2

1. Window > Library > Options > New Symbol

2. Name : botão2 ; behavior : button

3. Selecione a ferramenta Rectangle 

4. Clique na ferramenta auxiliar do retângulo > Round Rectangle Radius e no item Corner Radius digite 10

5. Desenhe uma retângulo em vermelho

6. Digite em branco e Arial Black no botão a palavra CADASTRO

7. Selecione o botão > Crtl K para centralizar no sinal ( + ) o símbolo botão2

8. Vertical > Align > selecione o terceiro botão ;
Horizontal > Align > selecione o terceiro botão ;
Match Size > selecione o primeiro botão ( x ) ;
( x ) marque Align to Page

9. Selecione a linha do tempo os estágios Over, Down e Hit

10. F6 ou Insert > Keyframe

11. Selecione na linha do tempo o estágio Over

12. Selecione somente a palavra CADASTRO

13. Selecione a ferramenta de Texto e troque a cor para azul

14. Selecione na linha do tempo o estágio Down

15. Selecione somente a palavra CADASTRO

16. Selecione a ferramenta de Texto e troque a cor para amarelo

17. Deixe o estágio Hit como está , ou seja , igual ao estágio Up

18. Clique em Scene 1  para voltar a Cena 1

19. Arraste da Library ( Biblioteca ) o desenho do botão 2 para área de trabalho

20. Salve o arquivo como exer14.fla

21. Crtl + Enter e teste sua animação

22. Passe o mouse sobre o botão

23. Crtl + F4 para voltar a área de trabalho

EFEITO MASK – MÁSCARA

O Efeito de Máscara cria layers ( camadas ) que escondem parte de outros layers que estejam abaixo do layer em que foi criada a máscara

EXERCÍCIO 15  – EFEITO PADRONAGEM

1. Clique em 12.0 fps em modifique o tamanho da animação para 320 x 240 pixels
2. Selecione a ferramenta Brush ( Pincel ) e pinte com várias cores a área de trabalho

3. Selecione a linha do tempo = 40 e insira um frame > F5

4. Renomeie este layer como padronagem

5. Insira um layer acima e renomeie de texto

6. Clique no olho para esconder o layer da padronagem

7. Volte ao layer do texto e digite a  palavra : E F E I T O em arial black , 28

8. Selecione o texto > F8 para transformar em símbolo gráfico

9. Mova o texto para parte superior à esquerda

10. Insira um keyframe na linha do tempo = 10 e mova o texto para parte superior à direita

11. Insira um keyframe na linha do tempo = 20 e mova o texto para parte inferior à esquerda

12. Insira um keyframe na linha do tempo = 30 e mova o texto para parte superior à direita

13. Insira um keyframe na linha do tempo = 40 e mova o texto para parte superior à esquerda

14. Selecione a linha do tempo 1 até 49 > Create Tweening
15.  Clique no olho novamente do layer padronagem para que ele seja exibido

16. Clique sobre o layer texto > botão direito do mouse > Mask ( Máscara )

17. Observe que automaticamente os dois layers foram trancados ( cadeado )

18. Salve o arquivo como exer15.fla

19. Crtl + Enter para testar a animação

20. Crtl + F4 para voltar à area de trabalho

Observação : Neste exemplo pode-se também inserir uma imagem como padronagem, de preferência em extensão png  com 72 dpi de resolução , e fazer o mesmo efeito

EXERCÍCIO 16 – EFEITO SPOTLIGHTS – HOLOFOTE

1. Nomeie o layer de texto

2. Desenhe um quadrado e pinte de cinza

3. Retire as bordas

4. Selecione o quadrado > Crtl + K

5. Vertical > Align > marque terceiro botão

6. Horizontal > Align > marque terceiro botão

7. Match Size > marque o botão da cruz

8. (x ) Align to Page

9. Digite : Testando  ; em Arial Black , cor preta e tamanho 28

10. Selecione o Texto > Crtl + K

11. Vertical > Align > marque terceiro botão

12. Horizontal > Align > marque terceiro botão

13. Match Size > marque o botão do X

14. (x ) Align to Page

15. Selecione o texto > F8 > Name = texto ; behavior = graphic

16. Insira um  frame na linha 40 > F5

17. Insira um layer acima

18. Nomeie o layer de spot

19. Clique no lápis desde layer > botão à direita > Modify Layers > Hidden Others para esconder o layer texto

20. Desenhe uma bola pintada de azul 

21. Selecione a bola > F8 > Name = bola ; behavior = graphic

22. Clique no lápis desde layer > botão à direita > Modify Layers > Show All para mostrar o layer texto

23. Arraste a bola para antes da palavra Testando

24. Insira um keyframe na linha 40 e arraste a bola para depois da palavra Testando

25. Selecione a linha do tempo 1 > Create Motion Tweening 

26. Mantendo selecionada a linha do tempo 1 deste layer ( Spot ) > clique sobre o layer com botão direito do mouse > Mask  ( Máscara )

27. Clique no botão 12.0 fps e mude a cor do background para preto

21. Salve o arquivo como exer16.fla

28. Crtl + Enter e teste sua animação 

29. Crtl + F4 para voltar à area de trabalho
EXERCÍCIO 17 – MÁSCARA COM LISTAS

1. Desenhe uma padronagem , ou seja , colunas de duas cores : azul e mostarda
mas atenção ela tem que começar uma cor e terminar as listas com a outra cor

2. Insira um frame na linha do tempo 40

3. Selecione tudo  e agrupe a padronagem Crtl + G
4. Crtl + K para centralizar na área de trabalho

5. Renomeie o layer de padronagem 1

6. Selecione a padronagem > Crtl + C para copiar padronagem

7. Insira um layer acima  e renomeie de padronagem 2
8. Esconda o layer padronagem 1

9. Selecione a linha do tempo 1 do layer padronagem 2

10. Crtl + V para colar a padronagem

11. Mantendo a padronagem seleciona > Crtl + K para centralizar e
Modify > Transform > Flip Horizontal

12. Esconda o layer padronagem 2

13. Insira outro layer acima e renomeie de texto

14. Digite FLASH  em arial black , tamanho 28 e arraste para o lado esquerdo

15. Selecione o texto > F8 e crie um símbolo gráfico

16. Insira outro keyframe na linha 40

17. Arraste o texto para um lado direito

30. Selecione a linha do tempo 1 > Create Motion Tweening 

31. Mantendo selecionada a linha do tempo 1 deste layer ( Spot ) > clique sobre o layer texto  com botão direito do mouse > Mask  ( Máscara )

32. Exiba todos os layers

22. Salve o arquivo como exer17.fla

33. Crtl + Enter e teste sua animação 

34. Crtl + F4 para voltar à area de trabalho

EXERCÍCIO 18 - EFEITO VÍDEO

1. Este exemplo é uma simulação de uma imagem estática transformando numa cena de vídeo , ou seja, não é uma gif animada

2. O tamanho do arquivo será de 200 x 150

3.  File > Import e importe uma imagem com extensão png , resolução 72 dpi

4. Com a imagem selecionada > F8 e transforme em símbolo gráfico : foto
5. Renomeie o layer de foto

6. Insira um keyframe na linha do tempo 60

7. Com a imagem selecionada > Modify > Transform > Scale e Rotate

8. Scale = 60 e Rotate = 0

9. Centralize a imagem no centro da tela

10. Selecione a linha do tempo 1  > Create Motion Tweening
11. Insira um layer acima

12. Renomeie de retângulo

13. Desenhe um retângulo que ocupe 90% da tela e pinte de qualquer cor

14. Clique no frame 1 deste layer > Properties > Actions

15. FSCommand > Command = allowscale  e Arguments = false

16. Clique no layer retângulo com o botão direito do mouse > Mask

17. Salve o arquivo como exer18.fla
18. Crtl + Enter e teste sua animação 

19. Crtl + F4 para voltar à area de trabalho

EXERCÍCIO 19  - EFEITO DE TEXTO

1. Digite o texto : EFEITO DE TEXTO , arial black , tamanho 26 e pinte de dourado

2. Selecione o texto > Crl + K para centralizar

3. Crtl + C para copiar o texto

4. Renomeie o layer de texto 1
5. Selecione a linha do tempo 50 e insira frame

6. Esconda o layer texto 1

7. Insira um layer acima e renomeie de texto 2
8. Crtl + V para colar o texto

9. Crtl + K para centralizar o texto

10. Pinte o texto com uma cor amarela mais clara

11. Esconda o layer de texto 2

12. Insira um layer acima e renomeie de oval
13. Desenhe uma bola oval que seja tamanho de uma letra do texto

14. Seleciona a bola oval > F8 símbolo gráfico : oval 

15. Exiba os layers texto 1 e texto 2
16. Arraste o símbolo oval para o início do texto

17. Insira um keyframe na linha do tempo 50 do layer oval

18. Arraste o símbolo oval para o final do texto

19. Clique entre a linha do tempo 1 e 50 > Create Motion Tweening
20. Clique no layer oval > Mask ( Máscara )

21. Clique em 12.0 fps e mude o fundo para preto

20. Salve o arquivo como exer19.fla
21. Crtl + Enter e teste sua animação 

22. Crtl + F4 para voltar à area de trabalho

S O M

O Flash  aceita somente  as extensões wav e aif e não importa MP3 . O Flash 4.0 ao gerar um arquivo .swf, ele pega os arquivos wav ou aif e usa a compressão do MP3 para compactá-lo

 EDITORES DE WAV - que transformam mid em wav

http://www.goldwave.com 

http://www.soundforge.com 

 NOÇÕES SOBRE MP3
MPEG ( Picture Experts Group ) , mais conhecido com MP3 é um conjunto de técnicas de compressão para áudio e vídeo que reduz o tamanho dos arquivos 1/12 do original

Para tocar um arquivo MP3 é necessário utilizar um player ; os mais conhecidos são o WinAmp e o Microsoft Media Player 4.0 que vem junto com o Windows 98.

 NOÇÕES SOBRE WINAMP
O Winamp 2.10  é considerado o melhor player , isto é , permite transformar um som wav em compressão MP3. Ele é um shareware e pode ser obtido :

http://www.winamp.com 

Uma vez instalado no seu computador, todas as vezes que for aberto uma arquivo em MP3, o WinAmp é aberto e roda a música.

 COMO TRANSFORMAR UM WAV EM COMPRESSÃO MP3
1. Abra o Winamp 2.10

2. Menu > Options

3. Preference > Plugin-ins

4. Output > Nullsoft Disk Writer

5. Clique em configure > e selecione onde irá armazenar o arquivo.wav

 SITES SOBRE MP3
http://www.mp3.com
http://www.emusic.com
http://www.mp3place.com
 COMO INSERIR SOM NO FLASH
1. File > Import e importe o som em wav para cima da animação

2. Clique na linha do tempo que foi inserido o som

3. Frame Properties > Sound

4. Abrirá uma Caixa de Diálogo onde estão as propriedades do SOM

5. No item : Sound está o nome do arquivo do som

6. No item dos gráficos onde você pode alterar o volume do som

EFFECTS - EFEITOS

None
Nenhum efeito

Left Channel
O som sai na caixa de som da esquerda

Right Channel
O som sai na caixa de som da direita

Fade Left to Right
O som começa na caixa de som à esquerda e termina na direita

Fade Right to Left
O som começa na caixa de som à direita e termina na esquerda

Fade In
O som vai aumentando aos poucos

Fade Out
O som vai diminuindo aos poucos

Custom
Default do Flash

SYNC - SINCRONIZAÇÃO

Event
O som toca até que terminar de rodar a animação

Start
Iniciar som

Stop
Parar som

Stream
O som toca até terminar, mesmo que a animação não esteja mais rodando

No item Loops – determina quantas vezes o som irá tocar

Observação : Sons em botões devem ser no estágio Over e Down

 TRILHA SONORA
Para criar uma trilha sonora , siga os seguintes passos :

1. Crie uma animação

2. Selecione a linha do tempo que quiser inserir uma música

3. File > Import e importe um arquivo em wav para a animação

4. Com o botão direito do mouse sobre esta linha do tempo > Properties > Sounds

5. No item Sync escolha a opção Start ( Iniciar som )

6. Suponhamos que na linha do tempo 20 você queira parar este som, repita o mesmo procedimento mencionado acima e escolha a opção no item Sync Stop ( Parar som )

7. Suponhamos que queira inserir outro som na linha do tempo 21, , repita o mesmo procedimento mencionado acima e escolha a opção no item Sync Play ( Iniciar som )

8. Lembre-se de criar os efeitos disponíveis no item Effects

 EXPORTAR SONS COM COMPRESSÃO MP3 NO FLASH
1. Crie uma animação som som em extensão em wav

2. File > Publish Settings ou Arquivo > Ajuste de Publicação

3. Clique  no item Flash

4. Audio Stream ou Audio Event clique em Set ( Ajustar )

5. Caixa de Diálogo Sound Settings ( Ajuste do Som )

6. No item compression escolha a opção MP3 ; a compressão MP3 é indicada para trilhas sonoras

7. No item Bit Rate deixe em 16 kbps e

8. Nesta opção você  não pode converter o som de Stereo para Mono

9. No item Quality é recomendável que deixe em Fast ( Rápida )

Observações : Existe mais duas formas de compressão ADPCM e Raw
1. ADPCM é indicada para sons pequenos

2. Nesta opção você pode converter o som de Stereo para Mono

3. No item Sample Rate define em khz o som , é recomendável que se deixe em 22 Khz

1. Raw é a compressão que exporta o som na sua forma orginal

2. Nesta opção você pode converter o som de Stereo para Mono

 Dicas de Sites de Som WAV
http://www.wavcentral.com 

http://www.triage.easynet.co.uk/just.htm 

http://www.soundz.com 

ftp://ftp.htc.dk/pub/WAV 

http://www.stoutman.com/wavs/index.html 

ACTIONS  - AÇÕES

GO TO AND STOP
seleciona que deve ir para determinada parte da animação e parar

Scene – selecione a cena

Frame – seleciona o frame

Label – seleciona o label ( rótulo )

Expression – seleciona a expressão em javascript ; abrirá uma caixa onde é inserido a expressão ; clicando no botão da direita abrirá o editor de javascript 

Next Frame – seleciona próximo frame

Previous Frame – seleciona o frame previsto

Go to and Play – caso seja selecionado, que deve ir para determinada parte da animação e rodar a animação

PLAY
determina que em determinado frame a animação irá rodar

STOP
determina que em determinado frame a animação irá parar

TOGGLE HIGH QUALITY
retirar serrilhamento da animação em alta resolução

STOP ALL SOUNDS
para todos os sons da animação

GET URL
Determina uma página em html a ser linkada , um email ¸ ou para onde irá os dados de um  formulário

URL digite : http://www.betomarques.com/flash4 ; ou
mailto:webmaster@betomarques.com  ou
http://www.abc.com/cgi-bin/formmail.pl 


Windows – caso a página seja em frame , determina o target ( alvo ) do frame
Variables – determina qual o método de envio do formulário : Post ou Get

FSCOMMAND

Determina comandos especiais no Flash 

Commands
Arguments
Definição





For StandAlone Player

fullscreen
true / false
Animação será exibida ou não na tela todo do monitor

allowscale
true / false
Animação será exibida do tamanho que ela foi criada e não será redimensionada

showmenu
true / false


exec
-


quit
-
Em arquivos executáveis , um botão com comando quit , fecha todo o arquivo

LOAD / UNLOAD MOVIE
determina que em determinado frame irá rodar ou não uma animação

Action
Load movie into location
Unload movie from location
Load variables into location

URL

Location
Level
Target

Variables – uso do método post ou get para envio de dados de formulário

TELL TARGET

Determina a instância de um símbolo movieclip, um mesmo símbolo movieclip pode ter várias instâncias com ações diferentes; quando se insere um símbolo movieclip na área de trabalho > seleciona o símbolo > Properties > Definition > Instance Name : digita um nome para instância ; exemplo : bola1; selecione a linha do tempo > Properties > Action > Tell Target , observe que no lado direito está a instância bola1 ; clique nela duas vezes que ela irá para parte de baixo, no campo target ( alvo ) : /bola1

IF FRAME IS LOADED
determina que a animação irá rodar. Somente quando for totalmente carregada ; 
efeito : “ Imagens Carregando ....”

Scene
determina a cena

Frame
determina o frame

Expression
determina o script

ON MOUSE EVENTS
determina um efeito quando o mouse passa sobre o símbolo botão

Press
pressionar

Release
clicar dentro da área botão ( default do Flash ) ;  a ação é exercida quando aperta o botão no estágio Down

Outside Release
clicar fora da área do botão

Roll Over
passar por cima do botão ; usado em menus com submenus ( Track as Menu ) 

Roll Out
sair de cima do botão ; acontece quando o cursor sai de cima do estágio Hit do botão

Drag Over
clicar em qualquer parte e arrastar para dentro do botão

Drag Out
clicar dentro do botão e arrastar para fora do botão

Key Press
Pressionar determinada chave

IF

Condition
Caso uma ação seja verdadeira, determina uma ação

Add Else / Else If clause
Adicionar outra / adicionar outra se

LOOP

Condition
Determina uma ação, enquanto for uma condição for verdadeira

CALL

Frame
Chamar determinado frame

SET PROPERTIES

Set
Determina propriedades do movie clip

Target
Determina o alvo

Value
Determina valores às propriedades do movie clip

SET VARIABLES

Variable
Determina variáveis

Value
Determina valores às variáveis

DUPLICATE / REMOVE MOVIE CLIP
duplica ou remove um símbolo movie clip

Action
Determina ação

Target
Determina o alvo

New Name
Determina novo nome

Depth


DRAG MOVIE CLIP
arrasta Movie Clip

Start drag operation
início da operação para arrastar

Target
Alvo

Constrain into rectangle


Left
Esquerda

Top
Na parte superior

Right
Direita

Bottom
na parte inferior

Lock mouse to center
Trancar mouse no centro

Stop drag operation
Terminar a operação para arrastar

TRACE

Message
Determina o valor de uma expressão ou string

COMMENT

Comment
Insere comentário

ACTION SCRIPT

TIPOS DE ATRIBUIÇÃO À UMA VARIÁVEL

String
Determina um valor que não foi atribuído a uma variável, que pode ser uma expressão ou um valor númerico

Numeric Literal
Determina um valor numérico à string ícone 123   

Expression
Determina uma expressão à string  ícone =

Expression Editor
Editor de Expressões

EDITOR DE EXPRESSÕES - TIPOS DE OPERADORES





OPERADOR GERAL

()
define expressão ou seja a variável





OPERADORES NUMÉRICOS

+
adição

-
subtração

*
multiplicação

/
divisão

=
igual

<>
desigual

|
Ou

>
Maior

>=
Maior ou igual

<
Menor

<=
Menor ou igual





OPERADORES DE STRING

‘””’
Determina a string

&
E para strings

eq
Igual para strings

Ne
Desigual para strings

It
Menor para strings

gt
Maior para strings

le
Menor ou igual para strings

ge
Maior ou igual para strings





OPERADORES LÓGICOS

and
E

or
ou

not
não

EDITOR DE EXPRESSÕES - TIPOS DE FUNÇÕES 
é um conjunto de ações armazenadas até serem executadas





FUNÇÕES GERAIS

eval
Determina valor da variável

false
Falso

true
Verdadeiro

newline
Nova linha 

GetTimer
Determina milésimo de segundos que a animação começou a rodar








FUNÇÕES NUMÉRICAS

Int (var )
Declaração de uma variável com números inteiros

Random
Cria um número entre 0 e -1





FUNÇÕES DA STRING

Substring
Determina uma substring

Length
Determina comprimento da string

Chr
Determina em ASCII valores à string 

Ord
Determina à string valores em ASCII





PROPRIEDADES

GetProperty
Determina a propriedade de origem do Movie Clip

_x
Determina posição x do MovieClip

_y
Determina posição y do Movie Clip

_width
Determina largura do Movie Clip

_height
Determina altura do Movie Clip

_rotation
Determina rotação do Movie Clip

_target
Determina o alvo do Movie Clip em caso de uso de frames

_name
Determina nome da instância do Movie Clip

_url
Determina a URL de um botão Movie Clip

_xscale
Determina valor em porcentagem de x do Movie Clip

_yscale
Determina valor em porcentagem de y do Movie Clip

_currentframe
Determina o frame corrente do Movie Clip

_totalframes
Determina o número de frames do Movie Clip

_framesloaded
Determina o número de frames carregados do Movie Clip

_alpha
Determina a quantidade de alpha do Movie Clip

_visible
Determina a visibilidade do Movie Clip

_droptarget
Determina que o Movie Clip seja arrastado para outro Movie Clip 





PROPRIEDADES GLOBAIS

_highquality


_focusrect


_soundbuftime






FUNÇÕES MULTIBYETE DA STRING




MBString


MBLength


MBChr


MBOrd


BOTÕES AVANÇADOS

EXERCÍCIO 20 - BOTÃO COM SOM

1. Window > Library > Options > New Symbol

2. Name : botão ; behavior : button
3. Desenhe um botão

4. Crtl K para centralizar o botão meio do sinal ( + ) na edição do símbolo

5. Selecione na linha do tempo os estágios Over, Down e Hit

6. Insert > Keyframe ou F6

7. Selecione o estágio Over

8. Libraries > Sounds

9. Selecione o som Brick Drops ou importe um som com extensão wav

10. Arraste o desenho do som para cima do botão

11. Selecione o estágio Down

12. Selecione o som Camera Shutter ou importe um som com extensão wav

13. Arraste o desenho do som para cima do botão

14. Volte para Scene 1 ( Cena 1 )

15. Arraste da Library seu botão para área de trabalho

16. Clique sobre o botão > Properties > Action

17. Clique em ( + ) Get URL

18. Suponhamos o botão tenha link para página pesquisa.htm

19. No item URL digite : pesquisa.htm
No item Window digitaria o target ( alvo ) caso está pa;agina fosse exeibida dentro de frames ;
se fosse o botão para email, no item URL digitaria : mailto:nome@provedor.com.br
20. Salve o arquivo como exer20.fla
21. Crtl + Enter e teste sua animação 
22. Crtl + F4 para voltar à area de trabalho

EXERCÍCIO 21 - BOTÃO LIGA E DESLIGA SOM

1. Clique me 12.0 fps e cloque o fundo em preto

2. Window > Library > Options > New Symbol

3. Name : bola ; behavior : graphic
4. Desenhe uma bola em gradiente

5. Selecione a bola > Crtl K para centralizar

6. Window > Library > Options > New Symbol

7. Name : flash ; behavior : movie clip
8. Digite a palavra texto com tamanho 48

9. Crtl + K para centralizar

10. Crtl + B para transformar o texto em imagem

11. Com a ferramenta balde, pinte o texto em cor gradiente

12. Insira um frame na linha do tempo 50

13. Insira um layer acima e renomeie de bola

14. Arraste da library o símbolo bola para o lado esquerdo do texto na parte superior

15. Insira um keyframe na linha do tempo 50

16. Arraste a bola para parte de baixo

17. Clique sobre a bola com o botão direito do mouse > Properties > Collor Effects
Alpha : 0

18. Window > Librray > Options > New Symbol

19. Name : botão liga/desliga ; behavior : movie clip

20. Libraries > Buttons > Round Yellow

21. Arraste este símbolo para a edição do símbolo botão liga/desliga

22. Crtl K para centralizar

23. Modify > Transform > Scale and Rotate

24. Scale : 50 ; rotate : 0

25. Insira um blanck keyframe na linha do tempo 10 e 20

26. Renomeie o layer para botão

27. Selecione a linha do tempo 1 > Properties > Label : liga e Action > Stop
28. Selecione a linha do tempo 10 > Properties > Label : desliga e Action > Stop
29. Selecione a linha do tempo 1 > clique sobre o botão > Properties
On Mouse Events
( x ) Press
Stop All Sounds
Go to and Stop
( x ) Label : desliga
30. Selecione a linha do tempo 1 > clique sobre o botão > Properties
On Mouse Events
( x ) Press
 Go to and Stop
( x ) Label : liga
31. Insira um layer abaixo e renomeie som
32. Insira um blank keyframe na linha do tempo 10 e 20

33. Selecione a linha do tempo 1

34. Import um som com extensão wav para cima do botão;
quando se importa um som para o Flash , o som vai para Library > da library você arrasta o som para o botão

35. Selecione a linha do tempo 1 do layer som > Properties > Sounds
Effect : Custom ; Syn : Event e Loops : 500
36. Volte a Cena 1

37. Renomeie o layer para botão liga/desliga

38. Arraste da Libray o movie clip botão liga/desliga
39. Insira um layer abaixo e renomeie de flash

40. Arraste da Library o movie clip flash

41. Mantendo selecionada a linha do tempo 1 do layer flash > Properties
Action > Stop
42. Salve o arquivo como exer21.fla

43. Crtl + Enter e teste sua animação 
44. Crtl + F4 para voltar à area de trabalho

EXERCÍCIO 22 - BOTÃO COM MÁSCARA

1. Windows >Library > Options > New Symbol

2. Name : texto ; behavior : graphic

3. Digite : 
CLIQUE AQUI PARA
OBTER INFORMAÇÕES
DE NOSSOS SERVIÇOS ...
NOSSOS CLIENTES ...
PROMOÇÕES ...
E AS ÚLTIMAS NOVIDADES !!!!

4. Selecione o  texto > Crtl K para alinhar

5. Vertical > Align ( x ) terceiro botão

6. Horizontal > Align ( x ) terceiro botão

7. Match Size marque ( x )

8. Marque Align to Page

9. Windows > Library > Options > New Symbol

10. Name : máscara ; behavior : movie clip

11. Selecione o símbolo texto e arraste para a área de trabalho do símbolo máscara

12. Selecione o texto > Crtl K para alinhar

13. Vertical > Align ( x ) terceiro botão

14. Horizontal > Align ( x ) terceiro botão

15. Match Size marque ( x )

16. Marque Align to Page

17. Insira um keyframe na linha do tempo 40 e arraste o texto para cima

18. Selecione a linha do tempo 1 até 39 > Properties > Create Motion Tweening

19. Renomeie o layer de texto
20. Insira um layer acima do texto

21. Renomeie o layer de retângulo
22. Desenhe um retângulo por onde irá passar o texto em vermelho

23. Selecione o retângulo de modo que ele esteja no início do texto

24. Clique sobre o layer retângulo > botão direito do mouse > Mask ( Máscara )

25. Windows > Library > Options > New Symbol

26. Name : botão ; behavior : button

27. Desenhe uma bola e pinte

28. Selecione o  texto > Crtl K para alinhar

29. Vertical > Align ( x ) terceiro botão

30. Horizontal > Align ( x ) terceiro botão

31. Match Size marque ( x )

32. Marque Align to Page

33. Insira um keyframe nos estágios Over , Down e Up

34. Selecione o estágio Over
35. Windows > Library e arraste o movie clip máscara para o lado do botão

36. Volte à Cena 1

37. Arraste da Library o botão para área de trabalho

38. Salve o arquivo como exer22.fla

39. Crtl + Enter e teste sua animação 
40. Passe o mouse sobre o botão
41. Crtl + F4 para voltar à area de trabalho

EXERCÍCIO 23 - BOTÃO INVISÍVEL

1. Windows > Library > Options > New Symbol

2. Name : botão ; behavior : button

3. Desenhe uma bola e pinte

4. Selecione o  texto > Crtl K para alinhar

5. Vertical > Align ( x ) terceiro botão

6. Horizontal > Align ( x ) terceiro botão

7. Match Size marque ( x )

8. Marque Align to Page

9. Insira um keyframe nos estágios Over , Down e Up

10. Selecione o estágio Hit e delete
11. Volte à Cena 1

12. Arraste da Library o botão para área de trabalho

13. Observe que a área do botão invisível fica em ciano

14. Salve o arquivo como exer23.fla

15. Crtl + Enter e teste sua animação 
16. Passe o mouse sobre o botão
17. Crtl + F4 para voltar à area de trabalho

EXERCÍCIO 24 - BOTÃO HIERÁRQUICO

1. Crie seis botões

2. Primeiro botão = Promoção 1

3. Segundo botão = Promoção 2

4. Terceiro botão = Cliente 1

5. Quarto botão = Cliente 2

6. Quinto botão = Cadastro

7. Sexto botão = Pesquisa
** Todos os seis botões acima com estágios Up , Over, Down , Hit
8. Crie três botões

9. Primeiro botão = Promoções

10. Segundo botão = Clientes

11. Terceiro botão = Formulários
** Todos os três botões acima com estágios Up e Hit
12. Na área de trabalho ( canvas ) insira os botões : Promoções, Clientes, Formulários

13. Nomeie o layer como menu

14. Insira keyframe na linha do tempo 10 , 20 e 30

15. Insira Frame na linha do tempo 40


16. Insira uma layer acima do menu

17. Nomeie o layer como submenu
18. Insira blankframe na linha do tempo 10

19. Insira os botões : Promoção 1 e Promoção 2 ao lado do botão Promoções


20. Insira blankframe na linha do tempo 20

21. Insira os botões : Cliente 1 e Cliente 2 ao lado do botão Clientes

22. Insira blankframe na linha do tempo 30

23. Insira os botões : Cadastro e Pesquisa ao lado do botão Formulários


24. Insira um layer acima do submenu

25. Nomeie o layer como label/ação

26. Insira blankframe na linha do tempo 10, 20 e 30

27. Insira frame na linha do tempo = 40


28. Selecione o blankframe na linha do tempo = 1
Properties > Label = início  e Action = Stop
29. Selecione o blankframe na linha do tempo = 10
Properties > Label = promoções
30. Selecione o blankframe na linha do tempo = 20
Properties > Label = clientes
31. Selecione o blankframe na linha do tempo = 30
Properties > Label = formulários



32. Selecione a linha do tempo 1 do layer menu
Clique sobre o botão promoções > Properties
On Mouse Events ( x ) Release
Go to Stop e Label = Promoções
33. Selecione a linha do tempo 1 do layer menu
Clique sobre o botão clientes > Properties
On Mouse Events ( x ) Release
Go to Stop e Label = Clientes
34. Selecione a linha do tempo 1 do layer menu
Clique sobre o botão formulários > Properties
On Mouse Events ( x ) Release
Go to Stop e Label = Formulários

35. Selecione a linha do tempo 10 do layer menu
Clique sobre o botão promoções > Properties
On Mouse Events ( x ) Release
Go to Stop e Label = início
36. Selecione a linha do tempo 10 do layer menu
Clique sobre o botão clientes > Properties
On Mouse Events ( x ) Release
Go to Stop e Label = clientes
37. Selecione a linha do tempo 10 do layer menu
Clique sobre o botão formulários > Properties
On Mouse Events ( x ) Release
Go to Stop e Label = formulários

38. Selecione a linha do tempo 20 do layer menu
Clique sobre o botão promoções > Properties
On Mouse Events ( x ) Release
Go to Stop e Label = promoções
39. Selecione a linha do tempo 20 do layer menu
Clique sobre o botão clientes > Properties
On Mouse Events ( x ) Release
Go to Stop e Label = inicio
40. Selecione a linha do tempo 20 do layer menu
Clique sobre o botão formulários > Properties
On Mouse Events ( x ) Release
Go to Stop e Label = formulários

41. Selecione a linha do tempo 30 do layer menu
Clique sobre o botão promoções > Properties
On Mouse Events ( x ) Release
Go to Stop e Label = promoções
42. Selecione a linha do tempo 30 do layer menu
Clique sobre o botão clientes > Properties
On Mouse Events ( x ) Release
Go to Stop e Label = clientes
43. Selecione a linha do tempo 30 do layer menu
Clique sobre o botão formulários > Properties
On Mouse Events ( x ) Release
Go to Stop e Label = inicio

44. Para criar uma ação para os botões do submenu , você deve criar uma cena para cada submenu e inserir ações nestes botões conforme mencionados no próximo exercício


45. Salve o arquivo como exer24.fla

46. Crtl + Enter e teste sua animação 
47. Passe o mouse sobre o botão
48. Crtl + F4 para voltar à area de trabalho

EXERCÍCIO 25 – BOTÃO COM CENAS

1. Clique em 12.0 fps e coloque o fundo em preto

2. Window > Library > Options > New Symbol

3. Name : botão1 ; behavior : button
4. Desenhe uma bola e pinte com uma cor gradiente

5. Retire as bordas

6. Crtl K para centralizar

7. Insira um keyframe nos estágios Over, Down e Hit

8. Window > Library > Options > Duplicate para duplicar o botão 1

9. Name : botão2 ; behavior : button
10.  Pinte com uma cor gradiente diferente do botão 1

11. Crtl K para centralizar

12. Insira um keyframe nos estágios Over, Down e Hit

13. Window > Library > Options > Duplicate para duplicar o botão 2

14. Name : botão3 ; behavior : button
15.  Pinte com uma cor gradiente diferente do botão 2

16. Crtl K para centralizar

17. Insira um keyframe nos estágios Over, Down e Hit

18. Clique  duas vezes na Library sobre o desenho do botão 1 para reeditá-lo

19. Selecione o estágio Over

20. Escreva com letra branca do lado esquerdo do botão : APRESENTAÇÃO

21. Selecione o estágio Down

22. Escreva com letra branca do lado esquerdo do botão : CONHEÇA NOSSA EMPRESA

23. Clique  duas vezes na Library sobre o desenho do botão 2 para reeditá-lo

24. Selecione o estágio Over

25. Escreva com letra branca do lado esquerdo do botão : PROMOÇÕES

26. Selecione o estágio Down

27. Escreva com letra branca do lado esquerdo do botão : CONFIRA NOSSAS PROMOÇÕES DESTA SEMANA

28. Clique  duas vezes na Library sobre o desenho do botão 3 para reeditá-lo

29. Selecione o estágio Over

30. Escreva com letra branca do lado esquerdo do botão : CLIENTES

31. Selecione o estágio Down

32. Escreva com letra branca do lado esquerdo do botão : VEJA NOSSOS CLIENTES

33. Volte à Cena 1

34. Renomeie o layer de botão 1
35. Arraste o botão 1 da Library para a parte de cima da área de trabalho ( lado direito )

36. Insira um keyframe na linha do tempo 20 e 80

37. Insira um layer abaixo e renomeie de botão 2

38. Insira um blankframe na linha do tempo 20

39. Arraste da Library o botão 2 para cima do botão 1 ; observe que o botão 2 irá ficar atrás do botão 1

40. Esconda o layer do botão 1

41. Volte ao layer do botão 2 e insira um keyframe na linha do tempo 40

42. Arraste o botão 2 para baixo e para esquerda

43. Clique na linha do tempo entre 20 e 40 > botão direito do mouse > Create Motion Tweening 

44. Insira um layer abaixo e renomeie de botão 3

45. Insira um blankframe na linha do tempo 40

46. Arraste da Library o botão 3 para cima do botão 2 ; observe que o botão 3 irá ficar atrás do botão 2

47. Esconda o layer do botão 2

48. Volte ao layer do botão 3 e insira um keyframe na linha do tempo 60

49. Arraste o botão 2 para baixo e para esquerda

50. Clique na linha do tempo entre 40 e 60 > botão direito do mouse > Create Motion Tweening 

51. Selecione a linha do tempo 80 do layer botão 1
Properties > Action > Stop

52. Insert > Scene para inserir outra cena ( Scene 2 )

53. Digite Cena 2 e insira um keyframe na linha 50
Properties > Action > Stop

54. Renomeie o layer de texto

55. Insira um layer abaixo e renomeie de botão voltar
56. Libraries > Buttons > Yin/Yan
57. Modify > Transform > Scale and Rotate
Scale : 50 e Rotate 0

58. Clique sobre o botão Yin/Yan > Properties > Action
On Mouse Eventes ( x ) Release
Go to and Play > Scene 1 > Frame : 1 > ( x ) Go to and Play

59. Volte a Cena 1

60. Selecione linha do tempo 20 do layer botão 1
61. Clique sobre o botão > Properties > Action
On Mouse Eventes ( x ) Release
Go to and Play > Scene 2 > Frame : 1 > ( x ) Go to and Play

62. Insert > Scene para inserir outra cena ( Scene 3 )

63. Digite Cena 3 e insira um keyframe na linha 50
Properties > Action > Stop

64. Renomeie o layer de texto

65. Insira um layer abaixo e renomeie de botão voltar
66. Windows > Library > Yin/Yan
67. Modify > Transform > Scale and Rotate
Scale : 50 e Rotate 0

68. Clique sobre o botão Yin/Yan > Properties > Action
On Mouse Eventes ( x ) Release
Go to and Play > Scene 1 > Frame : 1 > ( x ) Go to and Play

69. Volte a Cena 1

70. Selecione linha do tempo 40 o botão 2
71. Clique sobre o botão 2 > Properties > Action
On Mouse Eventes ( x ) Release
Go to and Play > Scene 3 > Frame : 1 > ( x ) Go to and Play

72. Insert > Scene para inserir outra cena ( Scene 4 )

73. Digite Cena 4 e insira um keyframe na linha 50
Properties > Action > Stop

74. Renomeie o layer de texto

75. Insira um layer abaixo e renomeie de botão voltar
76. Windows > Library > Yin/Yan
77. Modify > Transform > Scale and Rotate
Scale : 50 e Rotate 0

78. Clique sobre o botão Yin/Yan > Properties > Action
On Mouse Eventes ( x ) Release
Go to and Play > Scene 1 > Frame : 1 > ( x ) Go to and Play

79. Volte a Cena 1

80. Selecione linha do tempo 60 o  botão 3
81. Clique sobre o botão 3 > Properties > Action
On Mouse Eventes ( x ) Release
Go to and Play > Scene 4 > Frame : 1 > ( x ) Go to and Play

82. Salve o arquivo como exer25.fla

83. Crtl + Enter e teste sua animação 
84. Passe o mouse sobre o botão
85. Crtl + F4 para voltar à area de trabalho

FORMULÁRIO

Para criar um botão : radio button ou check box é necessário criar um movie clip de cada botão e associar eles à um valor de uma variável na ação Set Variable

PROPRIEDADES DO CAMPO DE PREENCHIMENTO - TEXT FIELD 

· Variable ( Variável ) – o nome do campo de preenchimento

· Options ( Opções )
Draw border and background – exibe borda e fundo do campo de preenchimento
Password – insere senha , ou seja , só será exibido asteriscos no campo de preenchimento
Multiline – insere várias linhas
Word wrap – insere quebra de linha
Restrict text length – definir quantidade de caracteres para o campo de preenchimento
Disable editing – define que campo de preenchimento não pode ser inseridos dados pelo usuário e é usado para inserir informações do formulário
Disable selection – define que o usuário não possa selecionar texto no campo de preenchimento

· Outlines ( Forma de Fontes )
Do not insert font outlines – não inserir forma de fonte
Include all font outlines – inclui todos as formas de fonte
Include only specified font outlines : ( inclui somente a forma da fonte especificada )
* Uppercase – Todas as letras maiúsculas
* Lowercase – Todas as letras minúsculas
* Numbers – Números
* Punctuation - Pontuação
* Characters – Caracteres

EXERCÍCIO 26 – FORMULÁRIO

1. Clique  em 12.0 fps e marque ( x ) Grid para que seja exibido a grade

2. Clique no imã para que ele permaneça ativado

3. Desenhe um retângulo em azul claro de 6 quadradinhos x 1

4. Selecione todo o polígono > Crtl G para agrupar

5. Pule um quadradinho

6. Desenhe um retângulo em azul claro de 12 quadradinhos x 1

7. Selecione todo o novo polígono > Crtl G para agrupar

8. Selecione os dois retângulos e Crtl + D para duplicar

9. Com as setinhas do teclado arraste a cópia dos quadrados para parte de baixo dos quadrados

10. Repita o mesmo procedimento duplicando criando no total de 6

11. Selecione a primeira coluna de quadrados > Crl + K para alinhar

12. Selecione a segunda coluna de quadrados > Crl + K para alinhar

13. Selecione a ferramenta de texto > Arial Black  > 12 > Preto

14. Digite a palavra Nome

15. No quadrado abaixo : Email , depois Endereço , Cidade , Cep e Estado respectivamente

16. Selecione todos os textos > Crtl K para alinhar

17. Selecione a ferramenta texto > e a ferramenta auxiliar > Text Field

18. Coloque o cursor no quadradinho ao lado de Nome  para  inserir campo de preenchimento e aumente até que ocupe toda o quadradinho

19. Coloque o cursor no quadradinho ao lado de Email  para  inserir campo de preenchimento e aumente até que ocupe toda o quadradinho

20. Coloque o cursor no quadradinho ao lado de Cidade  para  inserir campo de preenchimento e aumente até que ocupe toda o quadradinho

21. Coloque o cursor no quadradinho ao lado de Cep  para  inserir campo de preenchimento e aumente até que ocupe toda o quadradinho

22. Coloque o cursor no quadradinho ao lado de Estado  para  inserir campo de preenchimento e aumente até que ocupe toda o quadradinho

23. Selecione o campo de preenchimento de Nome > botão direito do mouse > Properties > Text Field Properties ou Modify > Text Field

24. No item Variable digite : Nome e marque somente (do not include font outlines )

25. Selecione o campo de preenchimento de Email > botão direito do mouse > Properties > Text Field Properties ou Modify > Text Field

26. No item Variable digite : Email e marque somente (do not include font outlines )

27. Selecione o campo de preenchimento de Endereço > botão direito do mouse > Properties > Text Field Properties ou Modify > Text Field

28. No item Variable digite : Endereco ( sem ç – pois como os programas que rodam formulários são em inglês , eles não aceitam ç , hífen e acentos no campo de preenchimento ) e marque somente (do not include font outlines )

29. Selecione o campo de preenchimento de Cidade > botão direito do mouse > Properties > Text Field Properties ou Modify > Text Field

30. No item Variable digite : Cidade e marque somente (do not include font outlines )

31. Selecione o campo de preenchimento de Cep > botão direito do mouse > Properties > Text Field Properties ou Modify > Text Field

32. No item Variable digite : Cep e marque somente (do not include font outlines )

33. Selecione o campo de preenchimento de Estado > botão direito do mouse > Properties > Text Field Properties ou Modify > Text Field

34. No item Variable digite : Estado e marque somente (do not include font outlines )

35.  Libraries > Button ( Biblioteca > Botão )

36. Escolha o botão Push Botão Red e arraste para parte de baixo do formulário

37. Modify > Transform > Scale and Rotate

38. Scale : 50 ; Rotate : 0
39. Clique sobre o símbolo botão com o botão direito do direito

40.  Aqui você deve inserir o programa que roda os formulários aonde esteja hospedada a página, neste exemplo , será o formmail.pl
Action > Set Variable 
On (Press)

         Variable: recipient ; value : digite seu email
         Variable: subject ; value : digite : Cadastro de Alunos ( assunto do email a ser enviado com os dados preenchidos )

Variable : title ; value : Cadastro de Alunos ( título da página de confirmação )

         Variable: bgcolor ; value: #EAEAAE ( cor de fundo da página de confirmação )

         Variable: required ; value : Nome,Email ( campos obrigatórios )
        Variable: text_color ; value : #000080 ( cor do texto na página de confirmação )

      Get URL  
      URL : http://www.provedor.com.br/cgi-bin/formmail.pl
      Variables : post

41. Clique em 12.0 fps e mude o fundo para azul escuro e desmarque o grid para que ele seja desativado

42. Salve o arquivo como exer26.fla

43. Crtl + Enter e teste sua animação 
44. Crtl + F4 para voltar à area de trabalho

Observação :

O Formulário pode conter  radio buttons, checkbox ou menus pop-downs , basta criar movie clips ; existe alguns exemplos em Libraries > Buttons-Advanced ( Biblioteca > Botões Avançados )

COMO PUBLICAR UMA ANIMAÇÃO EM HTML

FERRAMENTA PUBLISH SETTINGS - ajustes para publicação

1. Cria-se uma animação e salva por exemplo beto.fla

2. Crtl + Enter para testar a animação e transformá-la Em beto.swf

3. File > Publish Setting

4. Abrirá uma Caixa de Diálogo : Publish Settings

5. No item Formats ( Formatos ) deixe marcado Flash ( .swf ) e HTML (.html ) e caso esteja usando no seu site a extensão .htm > desmarque a opção use default  names
 ( usar nomes default ) e troque a extensão para .htm 

6. Existem outras opções para o Formatos :
* generator template ( .swt ) – só é disponível se estiver instalado no seu computador o programa da macromedia chamado generator para criar páginas com flash dinâmico
* gif Image ( .gif  ) – cria uma imagem com extensão gif
* jpeg Image ( .jpg ) – cria uma imagem com extensão jpg
* png Image ( .png ) – cria uma imagem com extensão png
* windows projector ( .exe ) – cria arquivo executável para o windows
* macintosh projector ( .hqx ) – cria arquivo executável para o macintosh
* quick time ( . mov ) – cria uma animação para o QuickTime versão 4

7. No item Flash
* load order – determina a visualização do carregamento da animação :
bottom up ( de baixo para cima ) , top down ( de cima para baixo )
* generate size report – cria um relátorio em txt da animação que auxiliam a verificar determinados pontos da animação que estão mais lentos
* protect from import – protege o arquivo para que ele não seja importado na Internet e copiado
* omit trace actions – determina que o Flash não intreprete as ações do Trace
* jpeg quality – serve para controlar a compressão as imagens importadas e modificar a qualidade para retirar manchas indesejáveis
* audio stream  - ajusta a compressão do som através do botão set ( ajuste )
* audio event - ajusta a compressão do som através do botão set ( ajuste )
* override sound settings – caso sejá marcado modifica os ajustes feitos na animação referentes as Propriedades Originais do Som para os ajustes que você tenha feito no audio stream ou audio event
* version – determina o versão do flash que queira exportar a animação, porém os novos recursos que foram implementados no Flash 4.0, não são visualizados nas versões anteriores

8. No item HTML
* template – determina as formas de exibição em HTML
a ) flash only ( default ) – determina o uso das tags <object> e <embed>
     ( recomendável deixar esta opção para usuários inciantes )
b ) play with FSCommand - determina o uso das tags <object> e <embed> com a ação FSCommand e JavaScript
c )  image map – determina o uso de imagem mapeada , caso tenha optado no formato que a animação tenha as extensões .gif , .jpg e .png
d ) java player – determina o uso do Flash Java Player
e ) quick time – determina o usro da tag <embed> para visulização do filme no QuickTime versão 4.0
f ) user choice – determina que o usuário possa escolhar a forma de visualização do arquivo : em shockwave ou como uma imagem ; isto é feito através de JavaScript

* dimensions – determina as dimensões da animação : 
   width ( largura ) e height ( altura )
a ) match movie – determina que a animação será exibida no tamanho original que foi criada
b ) pixels – determina as dimensões em pixels
c ) percent – determina as dimensões em porcentagem

* playback – determina comandos para rodar a animação que são inseridos nas tags <object> e <embed>
a ) paused at start – determina que a animação só irá rodar , se houver um botão com uma ação paly ( rodar ) ; é recomendável deixar este item desmarcado para que a animação carregue normalmente
b ) loop – determina quantas vezes a animacão irá rodar
c ) display menu – determina a exibição do menu da animação para o usuário
d ) device font – determina que o usuário visualize no seu computador uma fonte sem serrilhamento ( anti-aliasing ), mesmo que não tenha esta fonte instalada

* quality – determina a qualidade da animação :
a ) low – baixa resolução , ou seja , qualidade na velocidade da animação é prioridade
b ) auto low – baixa resolução com serrilhamento ( anti-aliasing )
c ) auto high – alta resolução , ou seja , alta qualidade na velocidade da animação é prioridade
d ) high – alta resolução , ou seja , alta qualidade nas imagens e sem serrilhamento ( anti-aliasing ) ; esta opção é a recomendada
e ) best – melhor resolução , ou seja, as imagens da animação serão exibidas sem serrilhamento ( anti-aliasing ) ,  ou seja , não dá importância a velocidade da animação

* window mode – é aceito somente pelo Internet Explorer 4.0 ou superior
a ) window – a animação é exibida na janela do site
b ) opaque windowsless – a animação pode ser inserido comandos em DHTML
c ) transparent windowless – a animação é inserida com fundo transparente

* alignment – determina alinhamento da animação na tela
a ) default – exibe a animação centralizada na tela
b ) left – exibe a animação à esquerda da tela
c ) right -  exibe a animação à direita da tela
d ) top – exibe a animação na parte superior da tela
e ) bottom – exibe a animação na parte inferior da tela

* scale
a ) default – determina que a animação será exibida no tamanho que foi criada e em algumas vezes poderá aparecer as bordas
b ) no border – determina que a animação será exibida no tamanho que foi criada e sem bordas
c ) exact fit – determina que a animação será exibida no tamanho que foi criada , mesmo que haja perda na qualidade da animação

* flash alignment – determina a posição da animação dentro da sua área de trabalho que foi criada
a ) horizontal
b ) vertical
c ) top – na parte superior
d ) bottom – na parte inferior


Observação : Quando se publica a animação no Flash 4.0 , existe uma opção Flash Only que é o default, mas ele insere no html a lista o texto . Uma forma de contornar o problema é :

1. C:\Arquivos de Programas\Macromedia\Flash 4\HTML

2. Abra o arquivo default.html e insira os comandos:

Como é originalmente

$TTFlash Only (Default)

$DS

Use an OBJECT and EMBED tag to display Flash.

$DF

<HTML>

<HEAD>

<TITLE>$TI</TITLE>

</HEAD>

<BODY bgcolor="$BG">

<!-- URL's used in the movie-->

$MU

<!-- text used in the movie-->

$MT    <----------- Aqui está o problema

Como deve ficar

$TTSomenteFlash sem Texto

$DS

Utiliza as tags OBJECT e EMBED para mostrar o Flash, e nao lista o texto.

$DF

<HTML>

<HEAD>

<TITLE>$TI</TITLE>

</HEAD>

<BODY bgcolor="$BG">

<!-- URL's used in the movie-->

ARQUIVO EXECUTÁVEL COM FLASH

Para criar uma animação em arquivo executável siga os seguintes passos :

1. Crie uma animação e salve

2. Crtl + Enter para ele se transformar em swf

3. Abra o programa StandAlone Player que foi instalado junto com o Flash 4.0

4. File > Open ( Arquivo > Abrir )
abra seu arquivo .swf

5. File > Create Projector  ( Arquivo > Criar Projetor )

6. Caso esteja usando Windows salve o arquivo.exe
7. Caso esteja usando Macintosh salve o arquivo.hqx
TRATAMENTO DE IMAGENS

As extensões aceitas : bmp , gif , png , wmf, eps e dxf . O jpg é aceito, mais quando é vetorizada no Flash , ela perde muito a resolução , por isto,  é aconselhável a não usá-lo. A melhor resolução é png para imagens importadas. O wmf aumenta muito o arquivo , e a melhor compressão de imagens no flash é a swf ( do próprio flash )

Observações
1. Quando você importa um arquivo ele vem com bitmap > perde qualidade e cresce o tamanho do movie.

2. Não vale a pena vetorizar na maiorias dos casos no flash , pois perde a resolução ; uma maneira seria antes de importar, salvar sua imagem num editor de imagens como bmp e depois importar para o Flash

3. Quando você copia (Ctrl+C) do Corel/Free Hand e cola (Ctrl+V) no flash , ele vem com o vetorial, a qualidade fica boa mas também fica muito grande o movie

4. Use as ferramentas de desenho do Word 97 que com elas podem fazer desenhos 3d , e quando você copia e cola no flash o arquivo vem bem pequeno :
No Word  - criei um quadrado e ativei o 3D > Crtl + C > Flash3 > Ctrl + V > Modifty > Break Apart  duas vezes ou Crtl + B e agrupe a imagem Crtl + G
Caso faça um desenho chapado no Flash copie e cola no Word 97 e use as ferramentas de desenho e coloque em 3d 

5. No Corel – as imagens feitas no Corel em WMF (Windows Meta File).

6. No Photoshop – as imagens devem ser feitas em PNG 
7. No Freehand - as imagens devem ser feitas usando o comando ANIMATE do Xtras e depois exporta para SWF e importa no Flash 3
 

COMO IMPORTAR UMA IMAGEM

1. File > Import

2. Existem quatro opções para trabalhar com uma imagem importada :
Background
Usar dentro do desenho uma gif
Vetorizá-lo
Quebrá-lo para simular transparência

3. Selecione toda a imagem importada

4. Ctrl B ou  Modify > Break Apart

Observação : Quando se importar uma imagem ela logo será inserida na sua Library ; 

1. Clique em Windows > Library ou Crtl + L

2. Caso queira substituir esta imagem por outra, clique no pop-up ( seta ) da Library e escolha a opção properties

3. Clique no item Import e importe a imagem que irá substituir a que foi inserida anteriormente

4. Clique OK

IMAGEM COMO BACKGROUND

1. File > Import  e importe o background

2. Arrasta para o canto superior ( do lado esquerdo ) e com a tecla da seta para fazer os ajustes necessários

3. Para alterar o background da imagem : Modify > Movie

4. Uma imagem como cenário deve ser o último layer de uma Cena

COMO VETORIZAR UM BITMAP

1. Modify > Trace Bitmap

2. Abrirá uma Caixa de diálogo : Trace Bitmap

· Color Threshold para controlar a sensibilidade do trace aos meio tons, ou seja, quanto mais alto o valor, mais o seu vetorial se aproximara do número de cores existentes no bitmap.

· Minimum area - é a área mínima para o trace ; quanto menor valor , menor será os detalhes que esteja trabalhando com uma imagem . 

· Curve fit – é a definição de como trace interpretará as curvas da imagem que pode ser : Pixels , Very Tight ( Muito Apertado ) , Tight ( Apertado ) , Normal ,  Smooth ( Suave ) , Very Smooth ( Muito Suave ). 

· Corner Threshold – é a  definição dos cantos das curvas da imagem que pode ser : Many Corners ( Muitos Cantos ) , Normal  e Few Corners ( Poucos Cantos )

Observação :  Quanto maior a resolução do seu bitmap e mais contraste de cores houver, melhorar será para o Flash traçar as curvas 

RECURSO PARA OTIMIZAR AS CURVAS DE UMA IMAGEM

Modify > Curves > Optmize ou Ctrl + Alt + Shift + C  ; elimina as curvas desnecessárias

Observação : A qualidade de uma imagem importada para o Flash e depois exportada com extensão swf , em algumas vezes, geram manchas ou distorções indesejáveis ; para contornar isto :

1. File > Export Movie

2. Abrirá uma caixa de diálogo :

3. No item JPEG Quality se controla o nível de compressão JPEG

USANDO O BREAK APART PARA SIMULAR TRANSPARÊNCIA

1. File > Import

2. Selecione a imagem

3. Ctrl B ou  Modify > Break Apart

4. Clique na ferramenta Lasso
5.  Clique na Segunda varinha mágica 

6. Abrirá uma Caixa de Diálogo :

7. No item Threshold ( Abertura ) = 10  ; querendo mais precisão reduza o  numero.

8. No item a suavidade  (Smoothing ) ( Suavidade ) normal 

9. Clique na primeira varinha,

10. Clique nas áreas que você quer retirar de sua figura ; 

11. Selecione a área que deseja fazer simular transparência

12. Clique Delete 

USANDO TRACE BITMAP PARA SIMULAR TRANSPARÊNCIA

1. Outra forma para simular transparência : para vetorizar  Modify > Trace Bitmap 

2. Deletar as imagens da imagem da mesma forma

3. Clique fora da figura para deselecionar

Observação 
1. Para dar efeito fundo transparente  : crie sua animação com um fundo preto e salva ;

2. Só funciona no Windows e Internet Explorer versão 4.0 ou superior ;

3. As cores aceitas para transparência no Flash são as cores que estão na paleta de cores do Flash.

4. No código html colocar os parâmetros : 

  <PARAM NAME=”wmode” VALUE=”transparent”>

CRIAR IMAGEM TRANSPARENTE NO COREL

1. Criar um gif transparente no COREL e importá-lo no Flash com o fundo realmente transparente. 

2. Crie um desenho

3. As áreas que queira deixar transparente, coloque um preenchimento em preto;

4. Mande exportar a imagem no COREL para *.gif;

5. Selecione > Transparente

6. Clique OK

7. Aparecerá três botões : um desses botões é um conta gotas.

8.  Clique no conta gotas

9. Na imagem original e clique na cor preta onde queira que fique transparente.

10. Clique OK

11. Importe no Flash 

Informações sobre background transparente:

http://www.macromedia.com/support/flash/how/subjects/wless2/wless02.html 

USAR IMAGENS COMO TEXTURAS

1. File > Import e importe uma imagem
2. Crtl B ou Modify > Break Apart

3. Clique na ferramenta Dropper ( Conta Gotas ) para capturar a textura desejada

4. Observe que a ferramenta do Paint Bucket ( Balde de Tinta ) foi exibida a textura capturada

5. Clique na ferramenta Paint Bucket ( Balde de Tinta ) e pinte no lugar desejado

IMAGENS EM 3D

Existe um programa chamado Vecta 3D que exporta animações em 3D diretamente para o Flash que vem junto ao CD do Flash 4.0  ( versão demo ) .

Existe um plugin chamado Illustrate para 3DS Max 2.5 que renderiza a sua animação 3D diretamente em swf em gráficos vetorais. A versão demo pode ser obtida : http://www.davidgould.com 

MOVIE CLIP

EXERCÍCIO 27 - BOTÃO COM MOVIE CLIP

1. Windows > Library > Options > New Symbol

2. Name : modelo ; behavior : graphic

3. Desenhe uma bola como modelo do botão

4. Selecione a bola > Crtl K para centralizar

5. Windows > Library > Options > New Symbol

6. Name : anel ; behavior : movie clip

7. Arraste o símbolo modelo > Crtl K para centralizar

8. Insira um keyframe na linha do tempo 2

9. Selecione a bola > Modify > Transform > Scale and Rotate
Scale : 120 ; Rotate : 0

10. Clique sobre a bola > Properties > Collor Effect > Alpha : 75

11. Insira um keyframe na linha do tempo 3

12. Selecione a bola > Modify > Transform > Scale and Rotate
Scale : 120 ; Rotate : 0

13. Clique sobre a bola > Properties > Collor Effect > Alpha : 50

14. Insira um keyframe na linha do tempo 4

15. Selecione a bola > Modify > Transform > Scale and Rotate
Scale : 120 ; Rotate : 0

16. Clique sobre a bola > Properties > Collor Effect > Alpha : 50

17. Insira um keyframe na linha do tempo 5

18. Selecione a bola > Modify > Transform > Scale and Rotate
Scale : 120 ; Rotate : 0

19. Clique sobre a bola > Properties > Collor Effect > Alpha : 25

20. Windows > Library > Options > New Symbol

21. Name : texto ; behavior : graphic
22. Digite : Testando

23. Selecione o texto > Crtl K para centralizar

24. Windows > Library > Options > New Symbol

25. Name : texto_mov ; behavior : movie clip
26. Arraste da library o texto

27. Selecione o texto > Crtl K para centralizar

28. Insira um keyframe na linha 20

29. Mova o texto para à direita ( na parte superior da área de trabalho )

30. Clique na linha do tempo entre 1 e 20 > Create Tweening Motion

31. Windows > Library > Options > New Symbol

32. Name : botão ; behavior : button
33. Renomeie o layer de botão
34. Arraste da Library o modelo

35. Selecione o modelo > Crtl K para centralizar

36. Insira um keyframe nos estágios Over , Down e Hit

37. Insira um layer acima > layer 2

38. Selecione o estágio Up
39. Libraries > Movie Clip > Fish Movie Clip e arraste para cima do botão

40. Insira um blank keyframe no estágio Over , Down e Hit

41. Selecione o estágio Down

42. Windows > Library > e arraste o símbolo texto_mov para cima do botão

43. Insira um layer abaixo do layer botão > layer 3
44. Insira um blank keyframe nos estágios Up, Over , Down , Hit

45. Selecione o estágio Over
46. Arraste da Library o símbolo anel > Crtl K para colocá-lo exatamente atrás do botão

47. Volte a Cena 1 > arraste da Library o símbolo botão

45. Salve o arquivo como exer27.fla

46. Crtl + Enter e teste sua animação clicando no botão
48. Crtl + F4 para voltar à area de trabalho

EXERCÍCIO 28 - EFEITO VIBRAR TEXTO

1. Windows > Library > Options > New Symbol

2. Name :  texto ; behavior : graphic

3. Digite : F L A S H
4. Selecione a texto > Crtl K para centralizar

5. Windows > Library > Options > New Symbol

6. Name : vibrar ; behavior : movie clip
7. Arraste da Library o símbolo texto > Crtl K para centralizar

8. Selecione a linha do tempo 1 > Copy Frames

9. Insira um layer acima > selecione a linha do tempo 1 > Paste Frames 

10. Insira outro layer acima > selecione a linha do tempo 1 > Paste Frames

11. Renomeie os layers : acima , meio ,  abaixo
12. Insira um keyframe na linha do tempo 40 dos layers acima e abaixo

13. Insira um frame na linha do tempo 40 do layer meio

14. Esconda o layer meio e abaixo
15. Selecione a linha do tempo 40 do layer acima e com o auxílio das setinhas do teclados > clique 30 para cima e 30 para direita

16. Mantendo a linha do tempo 40 selecionada

17. Clique sobre o texto > Properties > Color Effect > Alpha : 0

18. Clique entre a linha do tempo 1 e 40 > Create Tweening Motion

19. Esconda o layer meio e acima
20. Selecione a linha do tempo 40 do layer abaixo e com o auxílio das setinhas do teclados > clique 30 para baixo e 30 para esquerda

21. Mantendo a linha do tempo 40 selecionada

22. Clique sobre o texto > Properties > Color Effect > Alpha : 0

23. Clique entre a linha do tempo 1 e 40 > Create Tweening Motion

24. Volte a Cena 1 e arraste o símbolo vibrar para área de trabalho

25. Salve o arquivo como exer28.fla

26. Crtl + Enter e teste sua animação
27. Crtl + F4 para voltar à area de trabalho

EXERCÍCIO 29 - BARRA DE ROLAGEM

1. Window > Library > Options > New Symbol

2. Name : texto ; behavior : graphic 

3. Digite um texto com várias linhas que vai rolar na barra de rodagem

4. Crtl K para centralizar o texto

5. Window > Library > Options > New Symbol

6. Name : texto_mov ; behavior : graphic 

7. Arraste o símbolo texto

8. Renomeie o layer de texto

9. Insira um keyframe na linha do tempo 2

10. Insira um keyframe na linha do tempo 30 e movimente o texto para a parte de cima

11. Clique entre as linhas do tempo 2 e 30 > Create Tweening Motion

12. Insira um layer acima

13. Renomeie o layer de ação
14. Insira um blank keyframe na linha do tempo 2 e 31

15. Selecione a linha do tempo 1 > Properties > Action > Go to Next Frame
16. Selecione a linha do tempo 2 > Properties > Action > Stop
17. Selecione a linha do tempo 31 > Properties > Action >  Go to Previous Frame
2ª PARTE - SUBIR

1. Windows > Library > Options > New Symbol

2. Name : subir ; behavior : movie clip
3. Libraries > Buttons > VCR Button Set > VCR Right
4. Arraste este botão para a edição deste novo símbolo

5. Crtl K para centralizar

6. Renomeie o layer de subir

7. Modify >  Transform > Scale and Rotate 
Scale : 30 Rotate : -90  ( Seta para Cima )

8. Insira um frame na linha do tempo 5

9. Insira um layer acima e renomeie de ação

10. Insira um blank keyframe na linha do tempo 2 e 3

11. Selecione a linha do tempo 1 > Properties > Action > Stop
12. Selecione a linha do tempo 2 > Properties > Action
Tell Target  > Target = ../rolar
Go to Previous Frame
13. Selecione a linha do tempo 3 > Properties > Action
Go to and Play ; Frame : 2
14. Insira um frame na linha do tempo 5

15. Selecione a linha do tempo 1 do layer seta

16. Clique no símbolo seta > Properties > Actions
On Mouse Events  > Press and Drag Over
Go to and Play > Frame : 2
Selecione End On
On Mouse Events > Press and Drag Out
Go to and Stop > Frame : 1

3ª PARTE  - DESCER

1. Windows > Library

2. Selecione o símbolo seta > Options > Duplicate

3. Name : descer ; behavior : movie clip
4. Observe que tem dois layers : seta e ação

5. Selecione o símbolo da descer

6. Modify > Transform > Scale and Rotate
Scale : 100 ; Rotate : 180

7. Selecione o layer ação
8. Observe que na linha do tempo 1 > Properties > Action > Stop
17. Observe que n a linha do tempo 2 > Properties > Action
Tell Target  > Target = ../rolar
Go to Previous Frame ; troque para Go to Next Frame
18. Observe que na linha do tempo 3 > Properties > Action
Go to and Play ; Frame : 2
19. Selecione a linha do tempo 1 do layer seta
20.  Observe no símbolo seta > Properties > Actions
On Mouse Events  > Press and Drag Over
Go to and Play > Frame : 2
Selecione End On
On Mouse Events > Release and Drag Out
Go to and Stop > Frame : 1

4ª PARTE

1. Window > Library > Options > New Symbol

2. Name : texto_rolante ; behavior : movie clip
3. Arraste da Library o símbolo texto_mov
4. Crtl K para centralizar

5. Clique sobre o texto_mov > Properties > Definition > Instance  Name : rolar
6. Insira as duas setas do lado direito do texto

7. Insira um layer acima : layer 2

8. Desenhe um retângulo por onde irá passar o texto e pinte da mesma cor

9. Clique sobre o layer 2  com o botão direito do mouse > Mask ( Máscara )

10. Volte a Cena l e insira o símbolo texto_rolante
11. Salve o arquivo como exer29.fla

12. Crtl + Enter e teste sua animação clicando nos botões
13. Crtl + F4 para voltar à area de trabalho

EXERCÍCIO 30 - MOVIE CLIP USANDO SET PROPERTY

1. Windows > Library > Options > New Symbol

2. Name : botão ; behavior : button
3. Desenhe um botão

4. Crtl K para centralizar e insira um keyframe nos estágios Over , Down e Hit

5. Selecione o estágio Over
6. Selecione o botão > Modify > Transform > Scale and Rotate
Scale : 120 ; Rotate : 0

7. Selecione o estágio Down
8. Selecione o botão > Modify > Transform > Scale and Rotate
Scale : 80 ; Rotate : 0

9. Windows > Library > Options > New Symbol

10. Name : avião ; behavior : movie clip
11. Libraries > Movie Clip > Biplane e arraste para edição do símbolo avião

12. Crtl K para centralizar

13. Mantendo o avião selecionado

14. Modify > Transform > Scale and Rotate
Scale : 30 ; Rotate : 0

15. Insira um keyframe na linha do tempo 60

16. Mova o avião de lugar

17. Clique entre a linha do tempo 1 e 60 > Create Tweening Motion

18. Volte a Cena 1

19. Arraste da Library o símbolo botão
20. Renomeie o layer de botão

21. Insira um novo layer e renomeie de avião

22. Arraste da Library o símbolo avião
23. Clique sobre o avião > Properties > Definition > Instance Name  digite : avião
24. Clique no botão > Properties > Actions
On Mouse Events ; ( x ) Release
Set Property > Set selecione Visibility ; target : avião ; value : 0  ; isto é , o avião irá desparecer quando for clicado o botão

25. Window > Library > selecione o símbolo botão

26. Options > Duplicate

27. Name : botão/aparece ; behavior : button
28. Volte a Cena 1

29. Insira um novo layer e renomeie de botão/aparece

30. Arraste da Library o símbolo botão/aparece para parte de baixo do primeiro botão

31. Selecione o botão/aparece > Properties > Collor Effect > Tint e pinte o botão de outra cor

32. Clique novamente sobre o botão/aparece > Properties > Actions
On Mouse Events ; ( x ) Release
Set Property > Set selecione Visibility ; target : avião ; value : 1  ; isto é , o avião irá aparecer quando for clicado o botão

33. Salve o arquivo como exer30.fla

34. Crtl + Enter e teste sua animação clicando nos botões
35. Crtl + F4 para voltar à area de trabalho

EXERCÍCIO 31 - BOTÃO TRACK AS MENU ITEM

1. Window > Library > Options > New Symbol

2. Name : menu ; behavior : graphic
3. Digite MENU >>

4. Crtl K para centralizar

5. Window > Library > Options > New Symbol

6. Name : cliente1 ; behavior : graphic
7. Digite CLIENTE 1

8. Crtl K para centralizar

9. Window > Library > Options > New Symbol

10. Name : cliente2 ; behavior : graphic
11. Digite CLIENTE 2

12. Crtl K para centralizar

13. Window > Library > Options > New Symbol

14. Name : cliente3 ; behavior : graphic
15. Digite CLIENTE 3

16. Crtl K para centralizar

17. Window > Library > Options > New Symbol

18. Name : botão1 ; behavior : button
19. Desenhe um retângulo > Crtl K para centralizar
20. Deixe os estágios Over , Down e Hit vazios

21. Window > Library > Options > selecione o botão 1 > Duplicate

22. Name : botão2 ; behavior : button
23. Pinte o botão com uma cor diferente

24. Insira um keyframe nos estágios Over e Down
25. Pinte o botão no estágio Over de outra cor

26. Pinte o botão no estágio Down de outra cor

27. Window > Library > Options > New Symbol

28. Name : botão_mov ; behavior : movie clip
29. Renomeie o layer de ação

30. Selecione a linha do tempo 1 > Properties > Action > Stop
31. Insira um blank keyframe na linha do tempo 5

32. Insira um frame na linha do tempo 10

33. Selecione a linha do tempo 5 > Properties > Definition
( x ) Label ; digite :  segue

34. Insira um layer abaixo e renomeie de botão

35. Arraste da Library o símbolo botão1
36. Crtl K para centralizar

37. Clique sobre o botão 1 > Properties > Action
On Mouse Events ; ( x ) Roll Over
Go to and Stop ; ( x ) Label > segue
38. Insira um keyframe na linha do tempo 5

39. Arraste da Library o símbolo botão 2 três vezes

40. Posicione-os do lado direito do botão 1 , um debaixo de outro

41. Clique nos três botões recém inseridos separadamente > Properties > Definition
( x ) Track as menu item
42. Insira um layer acima re renomeie de nomes
43. Arraste o símbolo menu para dentro do botão principal

44. Insira um keyframe na linha do tempo 5

45. Arraste os símbolos clientes 1 , 2  e 3 para dentro dos sub- menu

46. Windows > Library > Options > New Symbol

47. Name: botão invisível ; behavior : button

48. Deixe o estágio Up com blank keyframe

49. Deixe os estágios Over e Down vazios

50. Insira um blank keyframe no estágio Hit

51. Desenhe um retângulo grande que  seja maior que o botão 1 e os submenus juntos

52. Volte a edição do símbolo botão_mov
53. Insira um layer abaixo do layer botão e renomeie botão invisível
54. Insira um blank keyframe na linha do tempo 5

55. Arraste da Library o símbolo botão invisível de modo que cubra o menu e os sub-menus

56. Clique sobre o botão invisível > Properties > Actions
On Mouse Events ; ( x ) Roll Over
Go to and Stop ; Frame : 1
57. Volte à Cena 1 e arraste da Library o botão_mov

58.  Salve o arquivo como exer31.fla

59. Crtl + Enter e teste sua animação clicando nos botões
60. Crtl + F4 para voltar à area de trabalho

DRAG MOVIE CLIP

A ação Drag Movie Clip possibilita que o usuário ao clicar um objeto na animação possa movimentá-lo na tela e é usado no Flash 4.0 para criar games e lojas virtuais.

Os passos para transformar um objeto com ação Drag Movie Clip :

1.Transforme um símbolo gráfico em botão

2. Este botão só tem o estágio Up

3. Insira neste botão as ações :
On Mouse Events ; ( x ) Press
Drag Movie Clip ; ( x ) Start Drag Operation
target : digite um nome como alvo com ( / ) ; exemplo :  /bola
após On End
On Mouse Events ; ( x ) Release
Drag Movie Clip ; ( x ) Stop Drag Operation

4. Arraste o botão para a Cena 1

5. Clique sobre o botão > Properties > Definition
mude o tipo de símbolo de button para movie clip

6. Mantendo ainda aberta a Definition
Instance Name : digite o nome que você deu alvo alvo mencionado acima ; exemplo bola ( sem a barra )

EXERCÍCIO 32 - DRAG MOVIE CLIP

1. Windows > Library > Options > New Symbol

2. Name : ovo ; behavior : button

3. Libraries > Graphic > Static Graphics > Egg

4. Arraste para edição do botão ovo

5. Crl K para centralizar

6. Deixe os estágios Over, Down e Hit vazios

7. Clique sobre o botão > Properties > Actions
On Mouse Events ; ( x ) Press
Drag Movie Clip ; ( x ) Start Drag Operation
target : /ovo
após On End
On Mouse Events ; ( x ) Release
Drag Movie Clip ; ( x ) Stop Drag Operation

7. Windows > Library > Options > New Symbol

8. Name : rato ; behavior : button

9. Libraries > Graphic > Static Graphics > Mouse

10. Arraste para edição do botão rato

11. Crl K para centralizar

12. Deixe os estágios Over, Down e Hit vazios

13. Clique sobre o botão > Properties > Actions
On Mouse Events ; ( x ) Press
Drag Movie Clip ; ( x ) Start Drag Operation
target : /rato
após On End
On Mouse Events ; ( x ) Release
Drag Movie Clip ; ( x ) Stop Drag Operation

14. Windows > Library > Options > New Symbol

15. Name : bocão ; behavior : button

16. Libraries > Graphic > Static Graphics > Mouthman

17. Arraste para edição do botão bocão

18. Crl K para centralizar

19. Deixe os estágios Over, Down e Hit vazios

20. Clique sobre o botão > Properties > Actions
On Mouse Events ; ( x ) Press
Drag Movie Clip ; ( x ) Start Drag Operation
target : /bocão
após On End
On Mouse Events ; ( x ) Release
Drag Movie Clip ; ( x ) Stop Drag Operation

21. Volte a Cena 1

22. Arraste o botão ovo para área de trabalho

23. Clique sobre o botão ovo > Properties > Definition
mude o tipo de símbolo de button para movie clip

24. Mantendo ainda aberta a Definition
Instance Name : ovo
25. Arraste o botão rato para área de trabalho

26. Clique sobre o botão rato> Properties > Definition
mude o tipo de símbolo de button para movie clip

27. Mantendo ainda aberta a Definition
Instance Name : rato
28. Arraste o botão bocão para área de trabalho

29. Clique sobre o botão bocão > Properties > Definition
mude o tipo de símbolo de button para movie clip

30. Mantendo ainda aberta a Definition
Instance Name : bocão
31. Salve o arquivo como exer32.fla

32. Crtl + Enter e teste sua animação clicando e arrastando os botões
33. Crtl + F4 para voltar à area de trabalho

TELL TARGET

Tell Target envia ações para uma determinada instância de um símbolo. Instância é uma cópia de um símbolo que pode ser modificada tantas vezes forem necessárias, sem alterar a original.

EXERCÍCIO  33 –  USO DE TELL TARGET

1. Libraries > Movie Clips > Flish Movie Clip
2. Arraste o peixe para área de trabalho

3. Selecione o peixe > Crtl D para duplicar e coloque-o na parte inferior da tela

4. Libraries > Buttons > Push Button Red
5. Arraste o botão para área de trabalho

6. Selecione o botão > Modify > Transform > Scale and Rotate
Scale : 50 ; Rotate : 0

7. Selecione o peixe > Crtl + D para duplicar o peixe e arraste para baixo  do visor

8. Selecione o peixe > Crtl + D para duplicar  novamente o peixe e arraste para baixo  do visor

9. Digite abaixo do primeiro botão : PARAR

10. Digite abaixo do segundo botão : INICIAR

11. Digite abaixo do terceiro botão : PARAR/INICIAR

12. Selecione o primiero peixe > Properties > Definition

13. No item Instance Name : peixe1

14. Selecione o segundo peixe > Properties > Definition

15. No item Instance Name : peixe2

16. Selecione o botão primeiro botão
17. Properties > Actions
On Mouse Events ; ( x ) Release
Tell Target : target : /peixe1
Stop

18. Selecione o botão segundo botão
19. Properties > Actions
On Mouse Events ; ( x ) Release
Tell Target : target : /peixe1
Play


20. Selecione o terceiro botão

21. F8 > e crie um novo símbolo : Name : botão_mov ; behavior : movieclip
22. Clique duas vezes sobre o botão_mov > Definition > Edit

23. Observe que o símbolo botão_mov foi aberto para ser reeditado

24. Insira um keyframe na linha do tempo 2

25. Selecione a linha do tempo 1 > Properties > Action > Stop
26. Mantendo a linha do tempo 1 selecionada

27. Clique no botão botão_mov > Properties > Action
On Mouse Events ; ( x ) Release
Tell Target ; em target digite : ../peixe2
Stop
Selecione End Tell Target
Go to ; ( x ) Next Frame

28. Selecione a linha do tempo 2

29. Clique no botão_mov > Properties > Action
On Mouse Events ; ( x ) Release
Tell Target ; em target digite : ../peixe2
Play
Selecione End Tell Target 
Go to ;  ( x ) Previous Frame
30. Volte a Cena 1
31. Delete o terceiro botão e arraste da Library o botão_mov no lugar do terceiro botão

32. Salve o arquivo como exer33.fla

33. Crtl + Enter e teste sua animação clicando nos botões
34. Crtl + F4 para voltar à area de trabalho

EXERCÍCIO 34 - TELL TARGET SINCRONIZADO

1. Libraries > Movie Clip > Star Spinning e arraste para área de trabalho

2. Arraste o mesmo movie clip mais três vezes > totalizando quatro Star Spinning

3. Selecione o segundo Star Spinning > Properties > Color Effect

4. Tint > e pinte de verde
5. Selecione o terceiro Star Spinning > Properties > Color Effect

6. Tint > e pinte de azul
7. Selecione o quarto Star Spinning > Properties > Color Effect

8. Tint > e pinte de amarelo
9. Selecione a estrela vermelha > Properties

10. Definition > Instance Name : estrela1

11. Selecione a estrela verde > Properties

12. Definition > Instance Name : estrela2

13. Selecione a estrela azul > Properties

14. Definition > Instance Name : estrela3

15. Selecione a estrela amarela > Properties

16. Definition > Instance Name : estrela4
17. Selecione a linha do tempo = 1 > Properties > Action
Tell Target ; target : /estrela1
Stop
Selecione End Tell Target
Insira outro Tell Target ; target : /estrela2
Stop
Selecione End Tell Target
Insira outro Tell Target ; target : /estrela3
Stop
Selecione End Tell Target
Insira outro Tell Target ; target : /estrela4
Stop

18. Windows > Library  > Options > New Symbol

19. Name : invisível ; behavior : movie clip

20. Neste símbolo não irá desenhar nada, ele servirá apenas para comandar as ações do Tell Target

21. Insira blank keyframe na linha do tempo 15 , 30 e 45

22. Insira frame na linha do tempo 60


23. Selecione a linha do tempo 1 > Properties > Action
Tell Target ; target : /estrela1
Play

24. Selecione a linha do tempo 15 > Properties > Action
Tell Target ; target : /estrela3
Play

25. Selecione a linha do tempo 30 > Properties > Action
Tell Target ; target : /estrela4
Play

26. Selecione a linha do tempo 45 > Properties > Action
Tell Target ; target : /estrela2
Play

27. Arraste o movie clip invisível e arraste para o centro da tela
28. Salve o arquivo como exer34.fla

29. Crtl + Enter e teste sua animação
30. Crtl + F4 para voltar à area de trabalho

IF FRAME IS LOADED

REGRA BÁSICA
· Suponhamos que uma animação tenha 600 frames

· No primeiro frame > digite : Imagem Carregando ...

· No segundo frame > insira um keyframe e coloque a ação  If Frame is Loaded > frame 600 para esperar que carregue toda a animação

· Dentro do  If Frame is Loaded > aperte + novamente > Go to and Play ;  para o 4º frame onde começaria animação ; ( x  ) Go to and Play

· No terceiro frame > insira keyframe coloque uma ação Go to and Play para o frame 1 ; para ficar em loop até que carregue o 600º frame

· No quarto frame inicie a animação propriamente dita

· A melhor maneira de visualizar o Efeito If Frame is Loaded é online, por isto , teste seus trabalhos na Internet

EXERCÍCIO 35 - CARREGANDO IMAGENS

1. A melhor maneira de visualizar a ação If Frame is Loaded é online

2. Veja este efeito rodando : http://www.betomarques.com/flash/load1.htm
3. Windows > Library > Options > New Symbol

4. Name : carregando ; behavior : graphic

5. Digite em azul : Imagem Carregando ... 

6. Crtl K para centralizar o texto

7. Windows > Library > Options > New Symbol

8. Name : carregando_mov ; ; behavior : movieclip

9. Arraste o símbolo carregando para a edição do movieclip

10. Crtl K para centralizar

11. Insira keyframe na linha do tempo 2

12. Clique sobre o símbolo > Properties > Color Effects > Tint

13. Pinte de vermelho

14. Insira keyframe na linha do tempo 3

15. Clique sobre o símbolo > Properties > Color Effects > Tint

16. Pinte de verde

17. Insira keyframe na linha do tempo 4

18. Clique sobre o símbolo > Properties > Color Effects > Tint

19. Pinte de amarelo

20. Volte a Cena 1

21. Arraste da Library carregando_mov
22. Insira  keyframe na linha do tempo 5 e 10

23. Insira blank keyframe na linha 20

24. Libraries > MovieClip > Biplane  e arraste para área de trabalho

25. Modify > Scale and Rotate > Scale = 30 e Rotate = 0

26. Mova o avião para o lado superior à esquerda

27. Insira um keyframe na linha do tempo 80

28. Mova o avião para parte de baixo à direita

29. Clique entre a linha  do tempo 20 até 79 > Properties > Tweening > Motion

30. Insira blank keyframe na linha do tempo 81

31. Libraries > MovieClips > Fish Movie Clip para área de trabalho

32. Insira um keyframe na linha do tempo 150

33. Clique na linha do tempo 1 > Properties > Action
FSComammand > Command : allowscale ; Arguments : false ; para que a animação seja visualizada do tamanho que foi feita

34. Clique na linha do tempo 5 > Properties > Action
If Frame is Loaded > Frame = 150
Go to and Play > Frame : 20 ; onde começa realmente a animação
(x ) Go to and Play
End Frame is Loaded

35. Clique na linha do tempo 10 > Properties > Action
Go to and Play > Frame : 1 ; ( x ) Go to and Play para ficar em looping até que o 150º esteja carregado

36. Clique na linha do tempo 150 > Properties > Action
Stop  

37. Salve o arquivo como exer35.fla

38. Crtl + Enter e teste sua animação
39. Crtl + F4 para voltar à area de trabalho

EXERCÍCIO 36 - IMAGEM CARREGANDO USANDO LABEL

1. A melhor maneira de visualizar a ação If Frame is Loaded é online

2. Veja este efeito rodando : http://www.betomarques.com/flash/load2.htm 

3. Nomeie o layer de texto
4. Digite : Imagem Carregando ...

5. Insira blank keyframe na linha do tempo 31

6. Digite : Imagem Quase Carregando ...

7. Clique na linha do tempo 31 > Properties > Label : quase
8. Insira blank keyframe na linha do tempo 80

9. File > Import e importe uma imagem

10. Clique na linha 80 > Properties > Label : foto
11. Insira um keyframe na linha do tempo 100

12. Clique na linha do tempo 100 > Properties > Action > Stop
13. Insira um layer acima e nomeie de ação

14. Insira blank keyframe na linha do tempo 15 e 30

15. Clique na linha 1 > Properties > Action
FSComammand > Command : allowscale ; Arguments : false ; para que a animação seja visualizada do tamnho que foi feita

16. Clique na linha 15 > Properties > Action
If Frame is Loaded > Label : foto
Go to and Play ; Label : quase ; onde começa realmente a animação
(x ) Go to and Play
End Frame is Loaded

17. Clique na linha 30 > Properties > Action
Go to and Play > Frame = 1 ; ( x ) Go to and Play para ficar em looping até que o 80º esteja carregado

18. Salve o arquivo como exer36.fla

19. Crtl + Enter e teste sua animação
20. Crtl + F4 para voltar à area de trabalho

EXERCÍCIO 37 - EFEITO PORCENTAGEM

1. A melhor maneira de visualizar a ação If Frame is Loaded é online

2. Veja este efeito rodando : http://www.betomarques.com/flash/load3.htm 
3. Clique em 12.0 fps e em background coloque preto 

4. Tamanho 320 x 240 pixels

5. Nomeie o layer : texto
6. Digite : Imagem Carregando  10% ...

7. Insira um keyframe na linha do tempo 20

8. Selecione a linha 1 até a 19 e insira keyframes

9. Para cada 2 frames = 10%

10. Clique na linha  do tempo 3 e mude o texto para 20%

11. Faça a mesma coisa na linha do tempo 4

12. Repita o mesmo procedimento 

13. Linha 5 e 6 = 30%

14. Linha 7 e 8 = 40%

15. Linha 9 e 10 = 50% até ... Linha 19 e 20 = 100%

16. Insira blank keyframe na linha do tempo 30

17. Libraries > MovieClip > Chaser Light e arraste para área de trabalho

18. Insira keyframe na linha do tempo 40

21. Clique na linha do tempo 1 > Properties > Action
If Frame is Loaded > Frame = 40
Go to and Play > Frame : 3 ; (x ) Go to and Play
End Frame is Loaded

22. Clique na linha do tempo 2 > Properties > Action
Go to and Play > Frame : 1 ; ( x ) Go to and Play 

23. Insira blank keyframe na linha do tempo 41

24. Libraries > MovieClip > Fish e arraste para área de trabalho

25. Insira um keyframe na linha do tempo 60 

26. Clique na linha 3 > Properties > Action
If Frame is Loaded > Frame = 60
Go to and Play > Frame = 5 ; (x ) Go to and Play
End Frame is Loaded

27. Clique na linha do tempo 4 > Properties > Action
Go to and Play > Frame = 3 ; ( x ) Go to and Play

28. Insira blank keyframe na linha do tempo 61

29. Libraries > MovieClip > Star Spinning > e arraste três cópias para área de trabalho

30. Insira keyframe na linha do tempo 80

31. Clique na linha 5 > Properties > Action
If Frame is Loaded > Frame : 80
Go to and Play > Frame = 7 ; (x ) Go to and Play
End Frame is Loaded

32. Clique na linha 6 > Properties > Action
Go to and Play > Frame = 5 ; ( x ) Go to and Play

33. Insira um blank keyframe na linha do tempo 81

34. Windows > Library > MovieClip > Biplane e arraste para área de trabalho

35. Insira um keyframe na linha do tempo 100

36. Clique na linha do tempo 7 > Properties > Action
If Frame is Loaded > Frame = 100
Go to and Play > Frame : 9 ; (x ) Go to and Play
End Frame is Loaded

37. Clique na linha do tempo 8 > Properties > Action
Go to and Play > Frame : 7 ; ( x ) Go to and Play

38. Insira um blank keyframe na linha  do tempo 101

39. File > Import e importe uma imagem

40. Insira um keyframe na linha do tempo 120

41. Clique na linha do tempo 9 > Properties > Action
If Frame is Loaded > Frame : 120
Go to and Play > Frame : 11 ; (x ) Go to and Play
End Frame is Loaded

42. Clique na linha do tempo 10 > Properties > Action
Go to and Play > Frame : 9 ; ( x ) Go to and Play

43. Insira um blank keyframe na linha do tempo 121

44. File > Import e importe uma outra imagem

45. Insira um keyframe na linha do tempo 140

46. Clique na linha do tempo 11 > Properties > Action
If Frame is Loaded > Frame : 140
Go to and Play > Frame = 13 ; (x ) Go to and Play
End Frame is Loaded

47. Clique na linha do tempo 12 > Properties > Action
Go to and Play > Frame : 11 ; ( x ) Go to and Play

48. Insira um blank keyframe na linha do tempo 141

49. File > Import e importe uma outra imagem

50. Insira um keyframe na linha do tempo 160

51. Clique na linha do tempo 13 > Properties > Action
If Frame is Loaded > Frame : 160
Go to and Play > Frame : 15 ; (x ) Go to and Play
End Frame is Loaded

52. Clique na linha do tempo 14 > Properties > Action
Go to and Play > Frame : 13 ; ( x ) Go to and Play

53. Insira um blank keyframe na linha do tempo 161

54. File > Import e importe uma outra imagem

55. Insira um keyframe na linha do tempo 180

56. Clique na linha do tempo 15 > Properties > Action
If Frame is Loaded > Frame : 180
Go to and Play > Frame  : 17 ; (x ) Go to and Play
End Frame is Loaded

57. Clique na linha do tempo 15 > Properties > Action
Go to and Play > Frame : 15 ; ( x ) Go to and Play

58. Insira um blank keyframe na linha do tempo 181

59. File > Import e importe uma outra imagem

60. Insira um keyframe na linha do tempo 200

61. Clique na linha do tempo 17 > Properties > Action
If Frame is Loaded > Frame : 200
Go to and Play > Frame : 19 ; (x ) Go to and Play
End Frame is Loaded

62. Clique na linha do tempo 18 > Properties > Action
Go to and Play > Frame : 17 ; ( x ) Go to and Play

63. Insira um blank keyframe na linha  do tempo 201

64. File > Import e importe uma outra imagem

65. Insira um keyframe na linha do tempo 220

66. Clique na linha do tempo 17 > Properties > Action
If Frame is Loaded > Frame : 220
Go to and Play > Frame : 21 ; (x ) Go to and Play
End Frame is Loaded

67. Clique na linha do tempo 18 > Properties > Action
Go to and Play > Frame : 19 ; ( x ) Go to and Play

68. Salve o arquivo como exer37.fla

69. Crtl + Enter e teste sua animação
70. Crtl + F4 para voltar à area de trabalho

LOAD  UNLOAD MOVIE

Load Movie carrega uma animação num determinada URL 

UnLoad Movie  remove a animação em um determinado trecho da animação corrente

OBSERVAÇÕES
1. O load movie permite que você carregue um outro movie (.swf) por cima do seu movie já no browser . 

2. O movie clip e como um movie que já fica em looping (padrão) que pode usar para fazer animações 

3. Quanto se usa ação como Load Movie, precisa informar o nome do arquivo .swf e o Level ( nível ) em que deseja carregar. 

4. Quando usa Unload Movie, basta especificar o Level ( nível ) em que se encontra.

5. Quando carrega uma animação no mesmo nível em que já outra animação, este será substituído pelo nova.

6. Para descarregar todas as animações, exceto uma , pode usar uma única instância de botão ( ou ação de frame ) e com um único "On release" declarar vários "Unload Movies" ( especificando só os níveis ).

Como abrir um arquivo SWF dentro de outro
Para abrir um swf dentro de outro, adicionando uma ação, por exemplo, a um botão, através do Load Movie. Os argumentos são:

· URL: nome do arquivo flash que deseja carregar exemplo : beto.swf 
· Level #: a animação principal tem o level = 0. , caso nomeie outra animação com level =1, por exemplo, ele será exibido em cima da animação principal e assim por diante

C A L L

A ação Call ativa actions ou procura variáveis em movie clips e load movies

EXERCÍCIO 38 - USANDO ACTION CALL

1. Window > Library > Options > New Symbol

2. Name : botão ; behavior : button
3. Desenhe um botão

4. Insira um keyframe nos estágios Over , Down e Hit

5. Volte à Cena 1

6. Arraste o botão para Cena 1

7. Selecione a ferramenta de Texto > ferramenta auxiliar text field
8. Clique ao lado direito do botão e digite 1

9. Selecione a ferramenta Arrow ( Seta ) e clique sobre o campo de preenchimento > Properties
Variable : somar
( x ) draw border and background
( x ) do not include font outlines

10. Insira um blank keyframe na linha do tempo 2

11. Selecione a linha do tempo 1 > Properties > Action
Set Variable : Variable : somar ;  Value : 1
Stop
12. Selecione a linha do tempo 2 > Properties > Action
Set Variable : Variable : somar ;  Value : somar + 1
13. Volte a linha do tempo 1

14. Clique sobre o botão > Properties > Action
On Mouse Events ; ( x ) Release
Call ; Frame : 2

15. Salve o arquivo como exer38.fla

16. Crtl + Enter e teste sua animação
17. Crtl + F4 para voltar à area de trabalho

LOJA VIRTUAL

Uma das inovações do Flash 4.0 é que ela possibilita criar Loja Virtual  ou WebStore e para se criar uma , você precisa ter conhecimentos em programação. Uma maneira simples de cria um Loja Virtual :
1. Criar um movie clip com o produto que estará disponível para compra 
2. Dar o nome  da Instância : Instance Name : produto1
3. Nele voce coloca um botao invisivel com os action start drag (on press)  e stop drag (on release). O primeiro passo seria so isso para fazer o produto ser arrastado.

4. Criar um movie clip como cesta de compras
5. Dar o nome  da Instância : Instance Name : cesta

6. Criar um botão comprar onde será inserido as actions de cálculo, ou seja, teria que verificar através da actions Ifs quais os movie clips estão dentro da cesta. Isso é possivel fazer através do GetProperty de x
Por exemplo , se o produto1 estiver dentro da cesta então deve efetuar o cálculo, ou seja , fazer o cálculo de acordo com o nome do textfield  ( campo de preenchimento ) que esta no formulário de pedido

7. Caso tenha outros produtos é necessário colocar uma action If apontandando a variável correspondente ao textfield ( campo de preenchimento ) da sua quantidade

8. Para evitar que o usuário arraste um produto para lado ( eixo x fica menor ) e a compra é computada , insira uma outra action If para que ela verifique se a posição y do produto seja menor que a posição de y na cesta de compras; delimitando a região , já que x e y do produto tem que ser menor

9. O eixo x da cesta tem que ser menor que o eixo x dos produtos para que eles fiquem dentro da cesta. Para verificar melhor essa condicao : ponto x e y dos movie clips devem estar em posições diferentes, exemplo :
* na edição do movie clip dos produtos , o símbolo tem que ficar no lado esquerdo ( na parte de cima ) do sinal ( + ) na edição do símbolo
* na edição do movie clip da cesta , o símbolo tem que ficar no lado direito ( na parte de baixo ) do sinal ( + ) na edição do símbolo

EXERCÍCIO 39 - LOJA VIRTUAL

1. Neste exemplo vamos fazer uma Loja Virtual de botões para camisas;
serão três tipos de botões : produto1 , produto2 e produto3
2. Window > Library > Options > New Symbol

3. Name : produto1 ; behavior : graphic
4. Desenhe um botão de camisa

5. Crtl K para centralizar

6. Crie mais dois símbolos gráficos , ou seja dois botões de camisa , e  os renomeie de produto2 e produto3 respectivamente

7. Window > Library > Options > New Symbol

8. Name : botão1 ; behavior : button
9. Arraste da Library o símbolo produto1

10. Crtl K para centralizar

11. Deixe os estágios over, down e hit vazios

12. Window > Library > Options > New Symbol

13. Name : botão1_mov ; behavior : movie clip
14. Arraste o símbolo botão1 para edição do movieclip

15. Importante : posicionar o botão do lado esquerdo do sinal ( + ) na parte de cima

16. Clique sobre o botão1 > Properties > Action
On Mouse Events ; ( x ) Press
Drag Movie Clip : ( x ) Start Drag Operation ; target : /produto1 ; ( x ) Lock mouse to center
Selecione End Drag
On Mouse Events ; ( x ) Release e ( x ) Release Outside
Drag Movie Clip ; ( x ) Stop Drag Operation

17. Window > Library > Options > New Symbol

18. Name : botão2 ; behavior : button
19. Arraste da Library o símbolo produto2

20. Crtl K para centralizar

21. Deixe os estágios over, down e hit vazios

22. Window > Library > Options > New Symbol

23. Name : botão2_mov ; behavior : movie clip
24. Arraste o símbolo botão2 para edição do movieclip

25. Importante : posicionar o botão do lado esquerdo do sinal ( + ) na parte de cima
26. Clique sobre o botão2 > Properties > Action
On Mouse Events ; ( x ) Press
Drag Movie Clip : ( x ) Start Drag Operation ; target : /produto2 ; ( x ) Lock mouse to center
Selecione End Drag
On Mouse Events ; ( x ) Release e ( x ) Release Outside
Drag Movie Clip ; ( x ) Stop Drag Operation

27. Window > Library > Options > New Symbol

28. Name : botão3 ; behavior : button
29. Arraste da Library o símbolo produto3

30. Crtl K para centralizar

31. Deixe os estágios over, down e hit vazios

32. Window > Library > Options > New Symbol

33. Name : botão3_mov ; behavior : movie clip
34. Arraste o símbolo botão3 para edição do movieclip

35. Importante : posicionar o botão do lado esquerdo do sinal ( + ) na parte de cima
36. Clique sobre o botão3 > Properties > Action
On Mouse Events ; ( x ) Press
Drag Movie Clip : ( x ) Start Drag Operation ; target : /produto3; ( x ) Lock mouse to center
Selecione End Drag
On Mouse Events ; ( x ) Release e ( x ) Release Outside
Drag Movie Clip ; ( x ) Stop Drag Operation


37. Window > Library > Options > New Symbol

38. Name : comprar ; behavior : button
39. Desenhe um botão escrito comprar

40. Importante : posicionar o botão do lado direito do sinal ( + ) na parte de baixo
41. Deixe os estágios Over e Down vazios

42. Insira um keyframe no estágio Up


43. Window > Library > Options > New Symbol

44. Name : enviar ; behavior : button
45. Desenhe um botão escrito enviar

46. Crtl K para centralizar

47. Isnira um keyframe nos estágios Over , Down e Hit


48. Window > Library > Options > New Symbol

49. Name : voltar ; behavior : button
50. Desenhe um botão escrito voltar

51. Crtl K para centralizar

52. Isnira um keyframe nos estágios Over , Down e Hit


53. Window > Library > Options > New Symbol

54. Name : cesta ; behavior : movieclip
55. Desenhe uma cesta de compras

56. Crtl K para centralizar


57. Volte à Cena 1

58. Renomeie o layer de texto
59. Digite : Loja Virtual  ; e pinte de azul

60. Digite :  Arraste para cesta os botões de camisa que queira comprar ; e pinte de preto

61. Insira um  blank keyframe na linha 2 e um frame na linha do tempo 10


62. Insira um layer abaixo e renomeie : produtos
63. Arraste da Library : botão1_mov , botão2_mov e botão3_mov
64.  Clique sobre botão1_mov , observe que o behavior está movieclip

65. Definition > Instance Name digite : produto1
66. Clique sobre botão2_mov , observe que o behavior está movieclip

67.  Definition > Instance Name digite : produto2

68. Clique sobre botão3_mov , observe que o behavior está movieclip

69. Definition > Instance Name digite : produto3
70. Insira um  blank keyframe na linha 2

71. Insira um layer abaixo e renomeie : cesta
72. Arraste da Libray a cesta

73. Clique sobre a cesta > Properties > Definition > Instance Name digite : cesta
74. Insira um  blank keyframe na linha 2


75. Insira um layer acima do layer texto e renomeie : comprar
76. Arraste da Libray o símbolo comprar

77. Clique sobre a cesta > Properties > Action
On Mouse Events ; ( x ) Release
If  ; Condition : GetProperty("/cesta",_x) <= GetProperty("/produto1",_x)
Set Variable :  Variable : qtde1  ;  Value : 1
Selecione End If
If  ; Condition : GetProperty("/cesta",_x) <= GetProperty("/produto2",_x)
Set Variable : Variable : qtde2  Value : 1
Selecione End If
If  ; Condition : GetProperty("/cesta",_x) <= GetProperty("/produto3",_x)
Set Variable :  Variable : qtde3 Value : 1
Selecione Set Variable: "qtde3" = 1
Selecione End If
Go to and Play ; Frame : 2 ; ( x ) Go to and Play

78. Insira um  blank keyframe na linha 2


79. Insira um layer acima  do layer comprar e renomeie : formulário
80. Insira um blank keyframe na linha do tempo 2

81. Desenhe um formulário com três colunas
Produtos , Qtde e Preço
82. Selecione a ferramenta de Texto > a ferramenta auxiliar Text Field

83. Clique abaixo de Produtos para inserir um campo de preenchimento e 
digite Produto 1

84. Selecione a ferramenta Arrow ( Seta )

85. Clique sobre o campo de preenchimento
Variable  digite produto1
Desmarque > Draw border and background
( x ) Disable editing ( para que o usuário não digite outro valor ao produto )
( x ) Do not include font outlines

86. Arraste da Library o símbolo produto1 e coloque ao lado esquerdo do campo de prenchimento do Produto 1
87. Repita o mesmo procedimento do item 82 à 86 e insira os campos de preenchimento produto2 e produto3


88. Selecione a ferramenta de Texto > a ferramenta auxiliar Text Field

89. Clique abaixo de Qtde para inserir um campo de preenchimento e digite 0 ( zero )
90. Selecione a ferramenta Arrow ( Seta )

91. Clique sobre o campo de preenchimento
Variable  digite qtde1
Desmarque > Draw border and background
( x ) Restrict text length to 3 characters
( x ) Do not include font outlines

92. Repita o mesmo procedimento do item 88 à 91e insira os campos de preenchimento qtde2 e qtde3

93. Selecione a ferramenta de Texto > a ferramenta auxiliar Text Field

94. Clique abaixo de Preços para inserir um campo de preenchimento e digite 10

95. Selecione a ferramenta Arrow ( Seta )

96. Clique sobre o campo de preenchimento
Variable  digite preco1 ( sem ç )
Desmarque > Draw border and background
( x ) Restrict text length to 3 characters
( x ) Disable editing ( para que o usuário não digite outro valor ao produto )
( x ) Do not include font outlines

97. Repita o mesmo procedimento do item 93 à 96 e insira os campos de preenchimento preco2 e preco3 , digitando no preco2 : 15 e no preco3 : 20


98. Abaixo do preco 3  digite Sub-Total
99. Selecione a ferramenta de Texto > a ferramenta auxiliar Text Field

100. Clique ao lado de Sub-total para inserir um campo de preenchimento
101. Selecione a ferramenta Arrow ( Seta )

102. Clique sobre o campo de preenchimento
Variable  digite subtotal ( sem hífen )
Desmarque > Draw border and background
( x ) Disable editing ( para que o usuário não digite outro valor ao produto )
( x ) Do not include font outlines


103. Abaixo do Sub-Total digite Frete
104. Selecione a ferramenta de Texto > a ferramenta auxiliar Text Field

105. Clique ao lado de Frete para inserir um campo de preenchimento e vamos dar um valor ao frete de 6, logo digite 6

106. Selecione a ferramenta Arrow ( Seta )

107. Clique sobre o campo de preenchimento
Variable  digite frete
Desmarque > Draw border and background
( x ) Disable editing ( para que o usuário não digite outro valor ao produto )
( x ) Do not include font outlines


108. Abaixo do frete  digite Total
109. Selecione a ferramenta de Texto > a ferramenta auxiliar Text Field

110. Clique ao lado de total para inserir um campo de preenchimento
111. Selecione a ferramenta Arrow ( Seta )

112. Clique sobre o campo de preenchimento
Variable  digite total
Desmarque > Draw border and background
( x ) Disable editing ( para que o usuário não digite outro valor ao produto )
( x ) Do not include font outlines


113. Abaixo do frete  digite Seus Dados
114. Digite : Nome
115. Selecione a ferramenta de Texto > a ferramenta auxiliar Text Field

116. Clique ao lado de nome para inserir um campo de preenchimento
117. Selecione a ferramenta Arrow ( Seta )

118. Clique sobre o campo de preenchimento
Variable  digite nome
Desmarque > Draw border and background
( x ) Restrict text length to 30 characters
( x ) Do not include font outlines


119. Digite : Email
120. Selecione a ferramenta de Texto > a ferramenta auxiliar Text Field

121. Clique ao lado de Email para inserir um campo de preenchimento
122. Selecione a ferramenta Arrow ( Seta )

123. Clique sobre o campo de preenchimento
Variable  digite email
Desmarque > Draw border and background
( x ) Restrict text length to 30 characters
( x ) Do not include font outlines


124. Digite : Endereço
125. Selecione a ferramenta de Texto > a ferramenta auxiliar Text Field

126. Clique ao lado de Endereço para inserir um campo de preenchimento
127. Selecione a ferramenta Arrow ( Seta )

128. Clique sobre o campo de preenchimento
Variable  digite endereco ( sem ç )
Desmarque > Draw border and background
( x ) Restrict text length to 30 characters
( x ) Do not include font outlines


129. Digite : Cidade
130. Selecione a ferramenta de Texto > a ferramenta auxiliar Text Field

131. Clique ao lado de Cidade para inserir um campo de preenchimento
132. Selecione a ferramenta Arrow ( Seta )

133. Clique sobre o campo de preenchimento
Variable  digite cidade
Desmarque > Draw border and background
( x ) Restrict text length to 30 characters
( x ) Do not include font outlines


134. Digite : Cep
135. Selecione a ferramenta de Texto > a ferramenta auxiliar Text Field

136. Clique ao lado de cep para inserir um campo de preenchimento
137. Selecione a ferramenta Arrow ( Seta )

138. Clique sobre o campo de preenchimento
Variable  digite cep
Desmarque > Draw border and background
( x ) Restrict text length to 09 characters
( x ) Do not include font outlines


139. Digite : Estado
140. Selecione a ferramenta de Texto > a ferramenta auxiliar Text Field

141. Clique ao lado de Estado para inserir um campo de preenchimento
142. Selecione a ferramenta Arrow ( Seta )

143. Clique sobre o campo de preenchimento
Variable  digite estado
Desmarque > Draw border and background
( x ) Restrict text length to 02 characters
( x ) Do not include font outlines


144. Insira um layer acima de todos e renomeie de label

145. Insira um blank keyframe nas linhas do tempo 2 , 4 , 6 e 8

146. Selecione a linha do tempo 2 > Properties > Definition > Label : comprar
147. Selecione a linha do tempo 4 > Properties > Definition > Label : repetir
148. Selecione a linha do tempo 6 > Properties > Definition > Label : processar
149. Selecione a linha do tempo 8> Properties > Definition > Label : somar


150. Insira um layer abaixo do label e renomeie de ação

151. Insira blank keyframe nas linhas do tempo 2 , 3 , 4 , 5 , 6 e 8

152. Selecione a linha do tempo 1 > Properties > Action > Stop
153. Selecione a linha do tempo 2 > Properties > Action > Call
Frame : somar
154. Selecione a linha do tempo 3 > Properties > Action > Go to and Play
Frame : 2 ; ( x ) Go to and Play

155. Selecione a linha do tempo 4 > Properties > Action > Call
Frame : somar
Go to and Play > Label : repetir ; ( x ) Go to and Play

156. Selecione a linha do tempo 5 > Properties > Action
If 
Condition : confirma = 1
Comment 
Comment : Enviado com Sucesso
Go to and Stop > ( x ) Label : somar
Volte para a primeira ação e selecione If [ confirma = 1 ]
Clique no botão do lado esquerdo Add Else/Else If clause
( x )else if
Condition: confirma = 2
Selecione Else If
Comment
Comment : Erro
Set Variable 
Variable : confirma
Go to and Play ;  ( x ) Label : comprar ; ( x ) Go to and Play


157. Selecione a linha do tempo 6 > Properties > Action
Go to and Play ; ( x ) Label : processar ; ( x ) Go to and Play


158. Selecione a linha do tempo 8 > Properties > Action
Comment
Comment : Total Calculado
Set Variable
Variable : subtotal
Value : (qtde1*preco1) + (qtde2*preco2 )+ (qtde3*preco3)
Set Variable
Variable : frete
Value : 6
Set Variable
Variable : total
Value : subtotal+frete
Comment
Comment : Formato para R$ 0.00
Set Variable
Variable : x
Value : subtotal
Call
Frame : formato
Set Variable
Variable : x
Value : frete
Call
Frame : formato
Set Variable
Variable : x
Value : total
Call
Frame : formato

159. Volte ao layer formulário e selecione a linha do tempo 2

160. Arraste da Library os botões enviar e voltar
161. Selecione o botão enviar > Properties > Action
Aqui você deve inserir o programa que roda os formulários aonde esteja hospedada a página, neste exemplo , será o formmail.pl
Action > Set Variable 
On (Press)

         Variable: recipient ; value : digite seu email
         Variable: subject ; value : digite : Loja Virtual – Lista de Compra ( assunto do email a ser enviado com os dados preenchidos )

Variable : title ; value : Loja Virtual ( título da página de confirmação )

         Variable: bgcolor ; value: #EAEAAE ( cor de fundo da página de confirmação )

         Variable: required ; value : nome,email ( campos obrigatórios )
        Variable: text_color ; value : #000080 ( cor do texto na página de confirmação )

      Get URL  
      URL : http://www.provedor.com.br/cgi-bin/formmail.pl
      Variables : post

162. Selecione o botão voltar > Properties > Action
On Mouse Events ; ( x ) Release
Go to and Play ; Frame : 1 ; ( x ) Go to and Play


163. Salve o arquivo como exer39.fla

164. Crtl + Enter e teste sua animação
165. Crtl + F4 para voltar à area de trabalho

CHAT ANIMADO

Este exemplo de Chat Animado vamos rodar o chat em asp, e para isto, é necessário que você conheça algum tipo de programação ou consulte seu provedor para configurar o arquivo dochat.asp que segue anexo
Atenção : criando somente a animação em flash e criar a página html não basta para rodar o Chat

EXERCÍCIO 40 – CHAT ANIMADO

1. Salve o arquivo como exer40.fla
2. Windows > Library > Options > New Symbol

3. Name : setas ; behavior : movie clip
4. Libraries > Buttons-Advanced > Scroll Bar > Scroll Up
5. Arraste para a edição do movie clip setas

6. Renomeie o layer para setas
7. Modify > Transform > Scale and Rotate
Scale : 50 e Rotate : 0

8. Libraries > Buttons-Advanced > Scroll Bar > Scroll Down
9. Arraste para a edição do movie clip setas
10. Modify > Transform > Scale and Rotate
Scale : 50 e Rotate : 0

11. Insira um keyframe na linha do tempo 3

12. Insira um frame na linha do tempo 7

13. Volte a linha do tempo 1

14. Clique sobre o botão Scroll Up ( subir ) > Properties > Actions
On Mouse Events > Press
Go to and Stop > Frame : 3
Set Variable : Variable: /:list.scroll
selecione abc que é string literal
Value: /:list.scroll-1
selecione  = que é expression
15.  Clique sobre o botão Scroll Down > Properties > Color Effect
Alpha : 50

16. Selecione a linha do tempo 3

17. Clique sobre o botão Scroll Up ( subir ) > Properties > Actions
On Mouse Events > Press
Go to and Stop > Frame : 3
Set Variable : Variable: /:list.scroll 
selecione abc que é string literal
Value: /:list.scroll-1
selecione  = que é expression
18.  Clique sobre o botão Scroll Down ( descer )  > Properties > Actions
On Mouse Events > Release
Go to and Play > Frame : 1 ( x ) Go to and Play

19. Insira um layer acima e renomeie de ações
20. Insira um blank keyframe nas linhas do tempo 1 , 2 e 3

21. Selecione a linha do tempo 1 > Properties > Actions
Comment : ir para o final da barra de rolagem
Set Variable : Variable : /:list.scroll 
selecione abc que é string literal
Value : /:list.maxscroll-1
22. Selecione a linha do tempo 2 > Properties > Actions
Go to and Play > Frame : 1 ( x ) Go to and Play
selecione  = que é expression

23. Windows > Library > Options > New Symbol

24. Name : processando ; behavior : graphic
25. Crtl K para centralizar


26. Windows > Library > Options > New Symbol

27. Name : processando_mov ; behavior : movie clip
28. Arraste o símbolo processando 

29. Crtl K para centralizar

30. Insira um keyframe na linha do tempo 2 , 3 , 4 e 5

31. Selecione a linha do tempo 2

32. Clique sobre o símbolo processando > Color Effect > Alpha = 75

33. Selecione a linha do tempo 3

34. Clique sobre o símbolo processando > Color Effect > Alpha = 50

35. Selecione a linha do tempo 4

36. Clique sobre o símbolo processando > Color Effect > Alpha = 25

37. Selecione a linha do tempo 5

38. Clique sobre o símbolo processando > Color Effect > Alpha = 0

39. Windows > Library > Options > New Symbol

40. Crie cinco botões : Enviar , Parar , Limpar , Iniciar e Atualizar
Todos os botões com estágios Up, Over , Down e Hit

41. Windows > Library > Options > New Symbol

42. Name : atualizando  ; behavior : movie clip
43. Renomeie o layer de botao_mov
44. Arraste o botão Parar para o lado esquerdo do sinal ( + ) da edição do símbolo

45. Insira um blank keyframe na linha do tempo 16

46. Arraste o botão Atualizar e o botão Iniciar para o lado esquerdo do sinal ( + ) 

47. Insira um layer acima e renomeie de processando
48. Arraste o símbolo processando_mov para o lado direito do sinal ( + ) da edição do símbolo

49. Insira um blank keyframe na linha do tempo 6

50. Insira um layer acima e renomeie de ações

51. Insira um blank keyframe na linha do tempo 15 e 16

52. Selecione a linha do tempo 1 > Properties > Actions
Tell Target > Target digite /
selecione abc que é string literal
Load Movie
   Action ( x ) Load variables into location
   URL : dochat.asp?action=update  ( aqui você insere o programa que vai  rodar seu chat , neste exemplo vamos usar o dochat.asp que vem junto com o CD do Flash 4.0 )
selecione abc que é string literal
   Location : ( x ) target
selecione abc que é string literal
   Variables > Send using Post

53. Selecione a linha do tempo 15 > Properties > Actions
Go to and Play > Frame : 1 ; ( x ) Go to and Play

54. Selecione a linha do tempo 1

55. Clique sobre o botão parar com o botão direito do mouse > Properties > Action
On Mouse Events ( x ) Release
Go to and Stop ( x ) Label digite : parar

56. Selecione a linha do tempo 16

57. Clique sobre o botão atualizar com o botão direito do mouse > Properties > Action
Tell Target > Target digite /
selecione abc que é string literal
Load Movie
   Action ( x ) Load variables into location
   URL : dochat.asp?action=update  ( aqui você insere o programa que vai  rodar seu chat , neste exemplo vamos usar o dochat.asp que vem junto com o CD do Flash 4.0 )
selecione abc que é string literal
   Location : ( x ) target
selecione abc que é string literal
   Variables > Send using Post

58. Clique sobre o botão iniciar com o botão direito do mouse > Properties > Action
On Mouse Events ( x ) Release
Go to and Play > Frame : 1 ; ( x ) Go to and Play

59. Volte a Cena 1


60. Digite : Sala

61. Clique em 12.0 fps e escolha uma cor para o background

62. Selecione a ferramenta do retângulo > Rounded Rectangle Radius = 10
Escolha uma cor branca para o contorno e a mesma cor para o preenchimento e desenhe o retângulo que será o campo de preenchimento de Sala


63. Digite : Nome

64. Selecione a ferramenta do retângulo > Rounded Rectangle Radius = 10
Escolha uma cor branca para o contorno e a mesma cor para o preenchimento e desenhe o retângulo que será o campo de preenchimento de Nome 

65. Digite : Bate Papo
66. Selecione a ferramenta do retângulo > Rounded Rectangle Radius = 10
Escolha uma cor branca para o contorno e a mesma cor para o preenchimento e desenhe o retângulo com altura maior que os campos já feitos, pois ele será o campo de preenchimento de Bate Papo


67. Digite : Mensagem
68. Selecione a ferramenta do retângulo > Rounded Rectangle Radius = 10
Escolha uma cor branca para o contorno e a mesma cor para o preenchimento e desenhe o retângulo que será o campo de preenchimento de Mensagem 


69. Selecione a ferramenta de texto > selecione Text Field

70. Desenhe o campo de preenchimento no retângulo ao lado de Sala
Digite : sala 1
71. Clique sobre o campo de preenchimento > Properties
Variable : id
( x ) restrict text length to 40 characters
( x ) do not include font outlines


72. Selecione a ferramenta de texto > selecione Text Field

73. Desenhe o campo de preenchimento no retângulo ao lado de Nome
Digite : anonimo   ( sem acento )
74. Clique sobre o campo de preenchimento > Properties
Variable : user
( x ) restrict text length to 40 characters
( x ) do not include font outlines


75. Selecione a ferramenta de texto > selecione Text Field

76. Desenhe o campo de preenchimento no retângulo ao lado de Bate Papo
77. Clique sobre o campo de preenchimento > Properties
Variable : list
( x ) Multline
( x ) Word Wrap
( x ) Disable editing
( x ) do not include font outlines


78. Selecione a ferramenta de texto > selecione Text Field

79. Desenhe o campo de preenchimento no retângulo ao lado de Mensagem
80. Clique sobre o campo de preenchimento > Properties
Variable : msg
( x ) restrict text length to 40 characters
( x ) do not include font outlines


81. Windows > Library e arraste o símbolo setas para o lado direito do campo de preenchimento de Bate Papo
82. Arraste o botão Enviar e Limpar para parte de baixo

83. Arraste o movie clip atualizando para abaixo dos botões Enviar e Limpar


84. Clique sobre o botão Enviar > Properties > Actions
On Mouse Events ( x ) Release ; ( x ) Key Press , clique no campo ao lado e pressione a tecla <Enter>
Load Movie
( x ) Load Variables into Location
URL : dochat.asp?action=send
selecione abc que é string literal
Location ( x) target
selecione abc que é string literal
Variables : ( x ) Send using Post


85. Clique sobre o botão Limpar > Properties > Actions
On Mouse Events ( x ) Release
Load Movie
( x ) Load Variables into Location
URL : dochat.asp?action=clear
selecione abc que é string literal
Location ( x) target
selecione abc que é string literal
Variables : ( x ) Send using Post


86. Clique sobre o símbolo atualizando > Properties > Definition
Instance Name digite a


87. Clique na linha do tempo 1 > Properties > Actions
Comment : caso o nome e a sala não for especificada, ele assume o default de anonimo
If > Condition id eq””
selecione = que é expression
Set Variable > Variable : id 
selecione abc que é string literal
Value : default
selecione abc que é string literal
Selecione End If
If > Condition name eq””
selecione = que é expression
Set Variable > Variable : name
selecione abc que é string literal
Value : anonimo
selecione abc que é string literal


88. Crtl + Enter e transforme exer40.fla em exer40.swf

Observação : Para enviar ao servidor os arquivos : exer40.swf , exer40.htm e dochat.asp ; não esqueça de solicitar ao servidor onde será hospedado o chat de como configurar o arquivo asp.


SITES SOBRE ASP

http://www.aspbrasil.com.br 

http://www.asplists.com/asplists/aspportuguese 
http://www.aspdeveloper.net
http://www.activeserverpages.com ( tutoriais )
http://paulen.cnw.com/adohelp ( asp )
http://www.genusa.com (asp )
http://www.barreto.com.br ( asp )
http://www.aspalliance.com
http://www.asphole.com/asphole/default.asp
http://www.genusa.com/asp
http://unlockingasp.siteam.com
http://www.riopreto.com.br/asp98
http://www.takempis.com
http://everest.igc.ups.br


HYPERLINK "http://www.vallin.com/pub/1/asp1.asp"
http://www.vallin.com/pub/1/asp1.asp
http://www.asptoday.com
http://www.aspzone.com

DICAS FINAIS

Como eliminar no browser as bordas na animação em Flash 

Insira um frameset na página e assim elimina as bordas no Internet Explorer e no Netscape

<frameset rows="100%,*" border="0" framespacing="0" frameborder="no">

<frame src="animacao.htm" name="animacao" frameborder="no" 

scrolling="no" marginwidth="0" marginheight="0" noresize>

</frameset>

Tamanho de Banner e Botão
468 X 60 Pixels ( Banner ) 

392 x 72 Pixels ( Banner com barra vertical navegação )

234 x 60 Pixels ( Banner pequeno )

120 x 240 Pixels ( Banner na vertical )  

120 x 90 Pixels ( Botão 1 ) 

120 x 60 Pixels ( Botão 2 ) 

125 x 125 Pixels ( Botão quadrado )

88 x 31 Pixels ( Botão pequeno )

Como scanear uma imagem sem perder a resolução e nitidez usando o Corel  Photo-Paint 8 para ser importada ao Flash
1. Digitalize a imagem em 300dpi com extensão png.

2. Abra o arquivo.png no Corel Photo-Paint 8

3. Selecione a imagem com a ferramenta de máscara em retângulo

4. Ctrl +Shift +C para fazer uma cópia da imagem , ou seja , um recusro do Corel chamado copiar visível

5. Feche o arquivo.png 

6. Arquivo >Novo da area de Transferencia ; assim criando uma nova imagem à partir da copia do arquivo.png

7. Com a ferramenta de seleção de objetos (seta) reduza o tamanho da imagem em cerca de 65% do tamanho original

8. Arquivo > Exportar em extensão png ; não entrelaçado

9. Entre no Flash > Arquivo > Importar > e importe a imagem


SCREENSAVER
O software para criar screensavers a partir do Flash.

http://www.macsourcery.com
TUTORIAS SOBRE FLASH
Flash Central - http://www.flashcentral.com  

Flash Pad - http://www.flasher.net/flashpad.html  

FlashZone - http://www.flashzone.com  

Macromania - http://www.users.bigpond.com/xtian/welcomenew.html  

Moock WebDesign Flash - http://colinmoock.iceinc.com/webdesign/flash/index.html   

T.I.P.'s - Flash - http://www.crazyraven.com/Tutorials/flash.htm  

http://rivendell.fortunecity.com/krondor/531/opensource.html 

PROGRAMAS PARA DIVIDIR IMAGEM
Programa freeware chamado PictureDicer  :  http://www.ziplink.net/~shoestring/dicer01.htm
Programa Fireworks da Macromedia  : http://www.macromedia.com/fireworks
ASSINATURA DIGITAL
http://www.digimarc.com  -  faz a assinatura digital ( watermark ) para proteger seus trabalhos e eles oferecem também serviços gratuitos

FLASH WRITER
Flash Writer está disponível gratuitamente para download. É um produto que permite aos usuários de Adobe Illustrator exportarem seus arquivos como swf

http://www.macromedia.com/software/flash/download/flashwriter 
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